hdu 5194

DZY Loves Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 400    Accepted Submission(s): 224


Problem Description
There are  n  black balls and  m  white balls in the big box.

Now, DZY starts to randomly pick out the balls one by one. It forms a sequence  S . If at the  i -th operation, DZY takes out the black ball,  Si=1 , otherwise  Si=0 .

DZY wants to know the expected times that '01' occurs in  S .
 

Input
The input consists several test cases. ( TestCase150 )

The first line contains two integers,  n m(1n,m12)
 

Output
For each case, output the corresponding result, the format is  p/q ( p  and  q  are coprime)
 

Sample Input
  
  
1 1 2 3
 

Sample Output
  
  
1/2 6/5
分析:(1)可以dfs枚举出所有情况
(2)也可以从期望的性质来考虑,期望的可加性
#include <iostream>
#include <stdio.h>
#include <string>
#include <string.h>
using namespace std;
int n,m;

int gcd(int a,int b)
{
   return b?gcd(b,a%b):a;
}

int main()
{
    while(cin>>n>>m)
    {
       int GCD=gcd(m*n,(n+m));
       printf("%d/%d\n",m*n/GCD,(n+m)/GCD);

    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值