解决“Maven项目中的Dynamic Web Module 3.0 requires Java 1.6 or newer”问题

错误描述

当创建有动态web模块3.0支持的项目时,需要用到Java版本不低于1.6。

在Markers标签页中显示的错误为:Dynamic Web Module 3.0 requires Java 1.6 or newer.

如图所示:


解决方法

注:有的时候1、2、3已经实现,直接跳过,操作4就OK了。

1、首先在Eclipse中安装JRE,Preferences > Java > Installed JREs,点击 Add,并添加自己的Java路径。


2、确认编译器版本不低于1.6,右键项目 > Properties > Java Compiler,保证“Compiler compliance level”不低于1.6。


3、保证项目的Facet中Java版本不低于1.6,右键项目 > Properties > MyEclipse > Project Facets > Java,保证“Java”不低于1.6。


4、在项目的pom.xml的标签中加入:

<plugins>
    <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-compiler-plugin</artifactId>
        <version>2.3.2</version>
        <configuration>
            <source>1.6</source>
            <target>1.6</target>
        </configuration>
    </plugin>
</plugins>

5、最后一步,右键项目 > Maven > Update Project。

阅读更多
版权声明:本文为博主原创文章,未经博主允许不得转载。 https://blog.csdn.net/conansix/article/details/37088063
个人分类: Java 错误排查
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭