找新朋友
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 79 Accepted Submission(s) : 39
Font: Times New Roman | Verdana | Georgia
Font Size: ← →
Problem Description
新年快到了,“猪头帮协会”准备搞一个聚会,已经知道现有会员N人,把会员从1到N编号,其中会长的号码是N号,凡是和会长是老朋友的,那么该会员的号码肯定和N有大于1的公约数,否则都是新朋友,现在会长想知道究竟有几个新朋友?请你编程序帮会长计算出来。
Input
第一行是测试数据的组数CN(Case number,1<CN<10000),接着有CN行正整数N(1<n<32768),表示会员人数。
Output
对于每一个N,输出一行新朋友的人数,这样共有CN行输出。
Sample Input
2
25608
24027
Sample Output
7680
16016
Author
Source
#include<stdio.h>
#include<math.h>
int eulre(int x) // 就是欧拉公式 注意:欧拉公式求的是 1——N 所有与 N 互质数的个数
{
int i, res = x;
for (i = 2; i < (int)sqrt(x * 1.0) + 1; i++)
if (x%i == 0)
{
res = res / i * (i - 1);
while (x % i == 0) x /= i; // 保证i一定是素数
}
if (x > 1) res = res / x * (x - 1); //大于sqrt(x)的质因子
return res;
}
int main()
{
int n,t;
scanf("%d", &t);
while (t--)
{
scanf("%d",&n);
printf("%d\n",eulre(n));
}
return 0;
}