Description
由于无敌的凡凡在2005年世界英俊帅气男总决选中胜出,Yali Company总经理Mr.Z心情好,决定给每位员工发奖金。公司决定以每个人本年在公司的贡献为标准来计算他们得到奖金的多少。
于是Mr.Z下令召开m方会谈。每位参加会谈的代表提出了自己的意见:“我认为员工a的奖金应该比b高!”Mr.Z决定要找出一种奖金方案,满足各位代表的意见,且同时使得总奖金数最少。每位员工奖金最少为100元。
Input
两个整数n,m,表示员工总数和代表数;
以下m行,每行2个整数a,b,表示某个代表认为第a号员工奖金应该比第b号员工高。
Output
若无法找到合法方案,则输出“-1”;否则输出一个数表示最少总奖金。
Sample Input
2 1
1 2
Sample Output
201
Hint
80%的数据满足n<=1000,m<=2000;
100%的数据满足n<=10000,m<=20000。
思路:
拿到这题,是拓扑排序
只要把他进入队列的时候记录下来
#include<iostream>
using namespace std;
int m,n,k,x,y,f[100000100],b[1000101],a[1000100][2];
struct node{
int to,next;
}b2[10001000];
int tot,hd[10010010];
void add(int x,int y){
tot++;
b2[tot].to=y;
b2[tot].next=hd[x];
hd[x]=tot;
}
void BFS(){
int tail=0,head=0;
for(int i=1;i<=n;i++){
if(b[i]==0){
tail++;
f[tail]=i;
a[i][1]=0;
}
}
if(tail==0){
cout<<-1;
k=1;
return;
}
while(head<tail){
head++;
int x1=f[head];
if(x1==0)continue;
for(int i=hd[x1];i;i=b2[i].next){
b[b2[i].to]--;
if(b[b2[i].to]==0){
tail++;
f[tail]=b2[i].to;
a[b2[i].to][1]=a[x1][1]+1;
}
}
}
}
int main(){
cin>>n>>m;
for(int i=1;i<=m;i++){
cin>>x>>y;
add(y,x);
b[x]++;
}
tot=0;
BFS();
m=0;
if(k==1)return 0;
for(int i=1;i<=n;i++){
m=m+100+a[i][1];
}
cout<<m;
}
但是,事伪所愿:
难道我在特判时错了吗(不要问我为什么不觉得主程序有错 )
我在后面加了一个入度为零的判断:
#include<iostream>
using namespace std;
int m,n,k,x,y,f[100000100],b[1000101],a[1000100][2];
struct node{
int to,next;
}b2[10001000];
int tot,hd[10010010];
void add(int x,int y){
tot++;
b2[tot].to=y;
b2[tot].next=hd[x];
hd[x]=tot;
}
void BFS(){
int tail=0,head=0;
for(int i=1;i<=n;i++){
if(b[i]==0){
tail++;
f[tail]=i;
a[i][1]=0;
}
}
if(tail==0){
cout<<-1;
k=1;
return;
}
while(head<tail){
head++;
int x1=f[head];
if(x1==0)continue;
for(int i=hd[x1];i;i=b2[i].next){
b[b2[i].to]--;
if(b[b2[i].to]==0){
tail++;
f[tail]=b2[i].to;
a[b2[i].to][1]=a[x1][1]+1;
}
}
}
}
int main(){
cin>>n>>m;
for(int i=1;i<=m;i++){
cin>>x>>y;
add(y,x);
b[x]++;
}
tot=0;
BFS();
m=0;
if(k==1)return 0;
for(int i=1;i<=n;i++){
if(b[i]!=0){m=-1;break;}
m=m+100+a[i][1];
}
cout<<m;
}