Let the Balloon Rise——c++

**

Let the Balloon Rise**

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 191200 Accepted Submission(s): 76633

Problem Description
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input
5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output
red
pink

Author
WU, Jiazhi

Source
ZJCPC2004

Recommend
JGShining | We have carefully selected several similar problems for you: 1002 1008 1005 1003 1009

#include<iostream>
//使用map集合map<k,v> 
using namespace std;
#include<string>
#include<iterator>//迭代器用于遍历集合
#include<map> 
int main(){
	string color;//存储颜色
	int n; cin>>n;
	int num;//与map中的值作比较 
	string result;//存储输出值 
	while (n> 0)
	{
		
		map<string,int> mymap;
 
		for (int i = 0; i <n; i++)
		{
			cin>>color;
			mymap[color]++;
		}
		
		num = 0;
		
		for (map<string,int>::iterator iter = mymap.begin(); iter != mymap.end(); iter++)
		{
			if(iter->second > num)//iter->second map中的值 
			{
				num = iter->second;
				result = iter->first;//iter->first  map中的键 --color
			}
		}
		cout<<result<<endl;
		cin>>n;
	}
	
	return 0;
} 

这里是引用 https://blog.csdn.net/feidewu/article/details/12895957

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值