1006Let the Balloon Rise ( 让气球上升)

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink
英语!呃硬伤,呵呵。
通过有道词典的强大,所以。。。。
#include<stdio.h>
#include <string.h>
void re(int m[])//由于不知道简单做法,所以。。。。
{
	int i;
	for(i=0;i<1000;i++)
			m[i]=0;
}
int main()
{
	int n,i,j,max[1000],m,k;
	char a[1000][20];
	while(scanf("%d",&n)!=EOF&&n!=0)
	{
		getchar();//解决gets得到不需要的值问题
		re(max);//清零
		k=n;
		while(k--)
		{
			gets(a[k]);
		}
		for(i=0;i<n;i++)//气球上升,就是冒泡排序啦(差不多)
			for(j=i+1;j<n;j++)
			{
				if(strcmp(a[i],a[j])==0)//没排,把出现的次数记下来
				{
					max[i]++;//用一维数组记录下标表示行数记录这一行的数据出现了几次(不过是从0开始的,不影响)
				}
				
			}
			m=0;//清零
			for(i=0;i<100;i++)//找到最大出现次数对应的下标
			{
				if(max[m]<max[i])
					m=i;
			}
			printf("%s\n",a[m]);//下标就是第几个颜色输出便可
	}
return 0;
}

自己做的,仿冒必究。
嘿嘿。。
0.0
 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值