zcmu 1893: String Game

http://acm.zcmu.edu.cn/JudgeOnline/problem.php?id=1893

1893: String Game

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 55   Solved: 20
[ Submit][ Status][ Web Board]

Description

Alice and Bob are playing the following game with strings of letters.

Before the game begins, an initial string and a target string are decided. The initial string is at least as long as the target string. Then, Alice and Bob take turns, starting with the initial string. Bob goes first. In each turn, the current player removes either the first or the last letter of the current string. Once the length of the current string becomes equal to the length of the target string, the game stops. If the string at the end of the game is equal to the target string, Alice wins the game; otherwise Bob wins.

Determine who will win the game if both players are playing optimally.

Input

Each test case starts with  N , the number of inputs to process. Each input consists of one line, which contains the initial string, followed by a space, followed by the target string. Each string consists of only lowercase letters. The total input length will be less than 500000 characters.

Output

For each input, output the winner, which will either be Alice  or Bob .

Sample Input

5
aba b
bab b
aaab aab
xyz mnk
xyz xyz

Sample Output

Alice
Alice
Bob
Bob
Alice


大致题意是:每回合每人可以删去字符串a的第一个或者最后一个字符,直到a的长度等于b的长度,此时若a=b,则
Alice胜。Bob先走。
Alice胜的情况:
1.很明显,如果b正好在a的中间,那么无论Bob删哪边,Alice删另一侧就可以了;
2.如果在b不a的中间,Alice先和Bob删异侧的,直达遇到b,假设此时的a是(b)...,那么如果b的后面有一或二 个字符,就可以在之前的Bob删a的最后一个字符的某次和Bob删同侧的,这样最后一回合的时候就会变成x(b)y【x,y代表一个字符】,则Alice胜;但是Bob可能一直删a的第一个字符,所以同理当 Bob 只删a的第一个字符时,应出现...(b)【b的前面只有一或二个字符】。
    综上:b不a的中间时,若 删去 a的第一个字符 an-bn为奇数 】(或前两个字符【an-bn为 偶数】) 或者删去a的最后 一个字符【an-bn为奇数】(或最后两个字符【an-bn为 偶数】) 能使b在a的中间,则Alice胜。

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#define maxn 500055

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        char a[maxn],b[maxn];
        scanf("%s%s",a,b);
        int an=strlen(a),bn=strlen(b),flag=0;
        int d=(an-bn)/2;
        if((an-bn)%2)
        {
            if(strncmp(a+d+1,b,bn)==0&&strncmp(a+d,b,bn)==0)
                flag=1;
        }
        else
        {
            if(strncmp(a+d,b,bn)==0)
                flag=1;
            else{
                if(strncmp(a+d+1,b,bn)==0&&strncmp(a+d-1,b,bn)==0)
                {flag=1;}
            }
        }
        if(flag)
            printf("Alice\n");
        else
            printf("Bob\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值