山东省第二届ACM大学生程序设计竞赛:Identifiers

Identifiers

Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^

题目描述

Identifier is an important concept in the C programming language. Identifiers provide names for several language elements, such as functions, variables, labels, etc.

An identifier is a sequence of characters. A valid identifier can contain only upper and lower case alphabetic characters, underscore and digits, and must begin with an alphabetic character or an underscore. Given a list of chararcter sequences, write a program to check if they are valid identifiers.

输入

The first line of the input contains one integer, N, indicating the number of strings in the input. N lines follow, each of which contains at least one and no more than 100 characters. (only upper and lower case alphabetic characters, digits, underscore (" "), hyphen ("-"), period ("."), comma (","), colon (":"), semicolon (";"), exclamation mark ("!"), question mark ("?"), single and double quotation marks, parentheses, white space and square brackets may appear in the character sequences.)

输出

For each of the N lines, output "Yes" (without quote marks) if the character sequence contained in that line make a valid identifier; output "No" (without quote marks) otherwise.

示例输入

7
ValidIdentifier
valid_identifier
valid_identifier
0 invalid identifier
1234567
invalid identifier
adefhklmruvwxyz12356790 -.,:;!?'"()[]ABCDGIJLMQRSTVWXYZ

示例输出

Yes
Yes
Yes
No
No
No
No

提示

来源

山东省第二届ACM大学生程序设计竞赛
#include <iostream>
#include <cstring>
#include <string>
#include <stdio.h>
using namespace std;
int judge1(char a)
{
    if((a>=97&&a<=122)||(a>=65&&a<=90)||(a=='_'))
        return 1;
    return 0;
}
int judge2(char a)
{
    if((a>=97&&a<=122)||(a>=65&&a<=90)||(a=='_')||(a>=48&&a<=57))
        return 1;
    return 0;
}
int main()
{
    int n;
    cin>>n;
    char b;
    cin>>b;
    while(n--)
    {
        char a[200];
        gets(a);
        if(judge1(a[0]))
        {
            int i=1,j=0;
            while(a[i]!='\0')
            {
                if(judge2(a[i]))
                {
                    j++;
                }
                i++;
            }
            if(j==i-1)
            {
                cout<<"Yes"<<endl;
            }
            else
                cout<<"No"<<endl;
        }
        else
        {
            cout<<"No"<<endl;
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值