SDUT 2163 Identifiers 山东省第二届ACM大学生程序设计竞赛

Identifiers

Time Limit: 1000MS Memory limit: 65536K

题目描述

 Identifier is an important concept in the C programming language. Identifiers provide names for several language elements, such as functions, variables, labels, etc.

An identifier is a sequence of characters. A valid identifier can contain only upper and lower case alphabetic characters, underscore and digits, and must begin with an alphabetic character or an underscore. Given a list of chararcter sequences, write a program to check if they are valid identifiers.

输入

 The first line of the input contains one integer, N, indicating the number of strings in the input. N lines follow, each of which contains at least one and no more than 100 characters. (only upper and lower case alphabetic characters, digits, underscore (" "), hyphen ("-"), period ("."), comma (","), colon (":"), semicolon (";"), exclamation mark ("!"), question mark ("?"), single and double quotation marks, parentheses, white space and square brackets may appear in the character sequences.)

输出

For each of the N lines, output "Yes" (without quote marks) if the character sequence contained in that line make a valid identifier; output "No" (without quote marks) otherwise.

示例输入

7
ValidIdentifier
valid_identifier
valid_identifier
0 invalid identifier
1234567
invalid identifier
adefhklmruvwxyz12356790 -.,:;!?'"()[]ABCDGIJLMQRSTVWXYZ

示例输出

Yes
Yes
Yes
No
No
No
No

分析:该题是判断字符串是否为有效标识符,标识符的要求是:

1、字符串内只能由数字,字符,下划线

2、数字不能打头

代码如下:

#include <stdio.h>
#include <string.h>

char str[1005];

int check()
{
	int i;
	if(str[0]>='0' && str[0]<='9')
		return 0;
	else
	{
		int len=strlen(str);
		
		for(i=0;i<len;i++)
		{
			if(!(str[i]>='0' && str[i]<='9' || str[i]>='a' && str[i]<='z' || str[i]>='A' && str[i]<='Z' || str[i]=='_'))
				return 0;
		}
	}
	return 1;
}

int main()
{
	int T;

	scanf("%d%*c",&T);
	while(T--)
	{
		memset(str,0,sizeof(str));
		gets(str);
		if(check())
			printf("Yes\n");
		else
			printf("No\n");
	}
	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值