Hdu 2222 . Keywords Search

12 篇文章 0 订阅
4 篇文章 0 订阅

Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.
Wiskey also wants to bring this feature to his image retrieval system.
Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.
To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

Input

First line will contain one integer means how many cases will follow by.
Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)
Each keyword will only contains characters ‘a’-‘z’, and the length will be not longer than 50.
The last line is the description, and the length will be not longer than 1000000.

Output

Print how many keywords are contained in the description.

Sample Input

1
5
she
he
say
shr
her
yasherhs

Sample Output

3

Solution

  • 这是一道经典的多模式串匹配问题,也是一道AC自动机模板题。

  • 不多说,上代码:

Code

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
const int N=500005;
struct AC_Automation
{
    int siz,ans;
    int trie[N][26],v[N],next[N],fail[N];
    void init()
    {
        siz=ans=0;
        memset(v,0,sizeof(v));
        memset(fail,0,sizeof(fail));
        memset(trie[0],0,sizeof(trie[0]));
    }
    void insert(char *p)
    {
        int len=strlen(p),j=0;
        for(int i=0;i<len;i++)
        {
            if(!trie[j][p[i]-'a'])
            {
                trie[j][p[i]-'a']=++siz;
                memset(trie[siz],0,sizeof(trie[siz]));
            }
            j=trie[j][p[i]-'a'];
        }
        v[j]++;
    }
    void getfail()
    {
        queue<int>que;
        for(int i=0;i<26;i++)
        {
            int x=trie[0][i];
            if(x)
            {
                fail[x]=next[x]=0;
                que.push(x);        
            }
        }
        while(!que.empty())
        {
            int now=que.front();
            que.pop();
            for(int i=0;i<26;i++)
            {
                int x=trie[now][i],y=fail[now];
                if(!x)
                {
                    trie[now][i]=trie[y][i];
                    continue;
                }
                que.push(x);
                while(y && !trie[y][i]) y=fail[y];
                fail[x]=trie[y][i];
            }
            next[now]=v[fail[now]]?fail[now]:next[fail[now]];
        }
    }
    void find(char *p)
    {
        int len=strlen(p);
        getfail();
        for(int i=0,j=0;i<len;i++)
        {
            j=trie[j][p[i]-'a'];
            for(int k=j;k;k=next[k])
                if(v[k]) ans+=v[k],v[k]=0;
        }
    }
}AC;
int main()
{
    int T,n;
    char p[55],s[N<<1];
    scanf("%d",&T);
    while(T--)
    {
        AC.init();
        scanf("%d",&n);
        while(n--)
        {
            scanf("%s",&p);
            AC.insert(p);
        }
        scanf("%s",&s);
        AC.find(s);
        printf("%d\n",AC.ans);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值