Smallest Sub Array-hihocoder-tiger

Given an array of integers A, find the smallest contiguous sub array B of A such that when you sort B in ascending order the whole array A becomes sorted as well.

For example if A = [1, 2, 3, 7, 4, 6, 5, 8] the smallest B will be [7, 4, 6, 5].  

输入

The first line contains an integer N denoting the length of A. (1 <= N <= 100000)

The second line contains N integers denoting the array A. (0 <= Ai <= 100000000)

输出

The length of the smalltest sub array B.

样例输入
8  
1 2 3 7 4 6 5 8
样例输出            4
#include <bits/stdc++.h>
using namespace std;
const int MAXN = 100010;
int chary[MAXN];
int main()
{
    freopen("in.txt", "r", stdin);
    int n, beg, endd;
    beg = endd = 0;
    int ans = 0;
    cin>>n;
    for( int i=0 ; i<n ; i++ )
        cin>>chary[i];
    int i,j;
    for( i=0 ; i<n-2 ; i++ )
    {
            if( chary[i] > chary[i+1] )
            {
                beg = i;
                break;
            }
    }
    for( i=n-2 ; i>=beg ; i-- )
    {
        if( chary[i] > chary[i+1] )
        {
            endd = i;
            break;
        }
    }
    sort( chary+beg, chary+endd+1 );
    int tmpmax = chary[endd];
    j = endd;
    for( i=n-1 ; i>= j ; i-- )
    {
        if( chary[i] < tmpmax )
        {
            endd = i;
            break;
        }
    }
    ans =  beg!=endd ? endd - beg + 1 : 0 ;
    cout<<ans<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值