Excel Sheet Column Title

好郁闷啊。。。。leetcoder上明明AC了,结果到了noj.io,我们学校自己的OJ上就超时了。。。。。。。。。

题目:http://noj.io/problem/p/1007

题目:

Description

Given a positive integer, return its corresponding column title as appear in an Excel sheet.

Input

There are multiple test cases.

The first line contain a positive integer N. means there are N test cases.

Following N lines, for each line there an integer M (1<=M<=2000000000).

Output

For each line output the M's corresponding excel column title.

Sample Input

6
1
2
3
26
27
28

Sample Output

A
B
C
Z
AA
AB
#include <iostream>
#include <cstdio>
using  namespace std;

string convertToTitle(long int n)
{
    string str;
    while(n)
    {
        int r=n%26;
        n=n/26;
        if(r==0)
        {
            str+='Z';
            n--;
        }else
        {
            str+=('A'+r-1);
        }
    }
    string result;
    for(int i=str.size()-1;i>=0;i--)
    {
        result+=str[i];
    }
    return result;
}
int main()
{
    //freopen("F:\\CSLeaning\\ExcelSheetColumnTitle\\in.txt", "r", stdin);
    int n;
    cin>>n;
    while ( n-- )
    {
        long int m;
        cin>>m;
        cout<<convertToTitle(m)<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值