HDU 2122 Ice_cream’s world III

B - Ice_cream’s world III
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input

Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output

If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input

     
     
2 1 0 1 10 4 0
 

Sample Output

     
     
10 impossible
 


最小生成树基础题目。

Prim算法。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define INF 0x3f3f3f3f
#define N 1005
using namespace std;
int graph[N][N];
int dis[N],vis[N];
int main()
{
        int n,m;
        while(scanf("%d%d",&n,&m)>0)
        {
                memset(vis,0,sizeof(vis));
                for(int i = 0; i < n; i++)
                {
                        graph[i][i] = 0;
                        for(int j = 0; j < i; j++)
                                graph[i][j] = graph[j][i] = INF;
                }
                int s,t,c;
                while(m--)
                {
                        scanf("%d%d%d",&s,&t,&c);
                        graph[s][t]=graph[t][s]=min(graph[s][t],c);
                }
                vis[0]=1;
                for(int i=0;i<n;i++)
                        dis[i]=graph[0][i];
                int minn,v,sum=0;
                for(int j=1;j<n;j++)
                {
                        minn=INF,v=-1;
                        v=-1;
                        for(int i=0;i<n;i++)
                                if(!vis[i])
                                        minn=minn>dis[i]?dis[v=i]:minn;
                        if(v==-1)
                                break;
                        vis[v]=1;
                        sum+=minn;
                        for(int i=0;i<n;i++)
                                if(!vis[i])
                                        dis[i] = min(graph[v][i],dis[i]);
                }
                if(v==-1)
                        printf("impossible\n");
                else
                        printf("%d\n",sum);
                printf("\n");
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值