HDOJ题目2122Ice_cream’s world III(最小生成树)

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 800    Accepted Submission(s): 272


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
  
  
2 1 0 1 10 4 0
 

Sample Output
  
  
10 impossible
 

Author
Wiskey
 

Source
 

Recommend
威士忌   |   We have carefully selected several similar problems for you:   2121  2119  2129  2118  2116 
 


prim算法模板

ac代码

#include<stdio.h>
#include<string.h>
#define INF 0xfffffff;
int map[1010][1010],v[10001];
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		int i,j,min,flag=0,sum=0;
		memset(v,0,sizeof(v));
		for(i=0;i<=1001;i++)
		{
			for(j=0;j<=1001;j++)
				map[i][j]=INF;
		}
		while(m--)
		{
			int a,b,c;
			scanf("%d%d%d",&a,&b,&c);
			if(c<map[a][b])//去重
				map[a][b]=map[b][a]=c;
		}
		v[0]=1;
		for(i=1;i<n;i++)
		{
			min=INF;
			flag=0;
			for(j=0;j<n;j++)
			{
				if(!v[j]&&map[0][j]<min)
				{
					min=map[0][j];
					flag=j;
				}
			}
			if(!flag)
				break;
			sum+=map[0][flag];
			v[flag]=1;
			for(j=0;j<n;j++)//更新权值
			{
				if(!v[j]&&map[0][j]>map[flag][j])
					map[0][j]=map[flag][j];
			}
		}
		if(i==n)
			printf("%d\n\n",sum);
		else
			printf("impossible\n\n");
		
	}
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值