POJ 2676 Sudoku

F - Sudoku
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

Sudoku is a very simple task. A square table with 9 rows and 9 columns is divided to 9 smaller squares 3x3 as shown on the Figure. In some of the cells are written decimal digits from 1 to 9. The other cells are empty. The goal is to fill the empty cells with decimal digits from 1 to 9, one digit per cell, in such way that in each row, in each column and in each marked 3x3 subsquare, all the digits from 1 to 9 to appear. Write a program to solve a given Sudoku-task.

Input

The input data will start with the number of the test cases. For each test case, 9 lines follow, corresponding to the rows of the table. On each line a string of exactly 9 decimal digits is given, corresponding to the cells in this line. If a cell is empty it is represented by 0.

Output

For each test case your program should print the solution in the same format as the input data. The empty cells have to be filled according to the rules. If solutions is not unique, then the program may print any one of them.

Sample Input

1
103000509
002109400
000704000
300502006
060000050
700803004
000401000
009205800
804000107

Sample Output

143628579
572139468
986754231
391542786
468917352
725863914
237481695
619275843
854396127



解数独。

题目意思很明显,就不解释了。

DFS+回溯

暴搜。

其实做完之后看起来这个DFS蛮简单的。

据Discuss里讲反向搜索貌似更快(0ms),可能是数据的原因吧。

做完之后看了看网上的题解,还有一种开三个数组剪枝的方法更优更高效。


#include <stdio.h>
#define N 9
int graph[N][N];
bool issolve=false;
bool isok(int x,int y,int value)
{
        for(int i=0;i<9;i++)
                if(graph[i][y]==value||graph[x][i]==value)
                        return false;
        int sx=x/3*3,sy=y/3*3;
        for(int i=sx;i<sx+3;i++)
                for(int j=sy;j<sy+3;j++)
                        if(graph[i][j]==value)
                                return false;
        return true;
}
void dfs(int k)
{
        if(k==81)
        {
                issolve=true;
                for(int i=0;i<9;i++)
                {
                        for(int j=0;j<9;j++)
                                printf("%d",graph[i][j]);
                        printf("\n");
                }
                return;
        }
        int x=k/9,y=k%9;
        if(graph[x][y])
                dfs(k+1);
        else
                for(int i=1;i<=9;i++)
                        if(isok(x,y,i))
                        {
                                graph[x][y]=i;
                                dfs(k+1);
                                if(issolve)
                                        return;
                                graph[x][y]=0;
                }
}
int main()
{
        int t;
        scanf("%d",&t);
        while(t--)
        {
                issolve=false;
                for(int i=0;i<9;i++)
                        for(int j=0;j<9;j++)
                                scanf("%1d",&graph[i][j]);
                dfs(0);
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值