ZOJ 1004 Anagrams by Stack

C - Anagrams by Stack
Time Limit:2000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]
and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.
Process

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item

We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o ois valid, but
i i o is not (it's too short), neither is
i i o o o i(there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

Sample Input

madam
adamm
bahama
bahama
long
short
eric
rice

Sample Output

[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]



DFS+STL:stack.

深搜+回溯。

题目大概意思是,给两个字符串A,B,问如何通过进出栈的方式让A变成B。

方法,从第0个位置开始匹配。每次取栈顶,如果相同,则继续DFS搜索下一个位置,如果不同,则回溯,重新枚举A中的下一位置去匹配。

说起来这样的搜索无疑是十分暴力的,不过数据量很少,也就过了。

#include <stdio.h>
#include <string.h>
#include <stack>
#define N 105
using namespace std;
stack<char> s;
int ans[N];
int la,lb,k;
char a[N], b [N];
void dfs(int x,int y)
{
        if(s.empty()&&y==lb)
        {
                for(int i=0;i<2*lb;i++)
                        if(ans[i])
                                printf("i ");
                        else
                                printf("o ");
                printf("\n");
        }
        if(x<la)
        {
                s.push(a[x]);
                ans[k++]=1;
                dfs(x+1,y);
                k--;
                s.pop();
        }
        if(!s.empty())
        {
                char temp=s.top();
                if(temp==b[y])
                {
                        s.pop();
                        ans[k++]=0;
                        dfs(x,y+1);
                        k--;
                        s.push(temp);
                }
        }
}
int main()
{
        while(scanf("%s%s",a,b)>0)
        {
                la=strlen(a),lb=strlen(b),k=0;
                printf("[\n");
                if(la==lb)
                        dfs(0,0);
                printf("]\n");
        }
        return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值