HDU 5003 Osu!

Osu!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1398    Accepted Submission(s): 655
Special Judge


Problem Description
Osu! is a famous music game that attracts a lot of people. In osu!, there is a performance scoring system, which evaluates your performance. Each song you have played will have a score. And the system will sort all you scores in descending order. After that, the i-th song scored a i will add 0.95^(i-1)*a i to your total score.

Now you are given the task to write a calculator for this system.
 

Input
The first line contains an integer T, denoting the number of the test cases.

For each test case, the first line contains an integer n, denoting the number of songs you have played. The second line contains n integers a 1, a 2, ..., a n separated by a single space, denoting the score of each song.

T<=20, n<=50, 1<=a i<=500.
 

Output
For each test case, output one line for the answer.

Your answers will be considered correct if its absolute error is smaller than 1e-5.
 

Sample Input
  
  
1 2 530 478
 

Sample Output
  
  
984.1000000000
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5431  5430  5429  5428  5427 
 

2014年ACM/ICPC鞍山赛区的一道签到题。

#include <stdio.h>
#include <math.h>
#include <algorithm>
#define N 55
using namespace std;
double num095[N];
int a[N];
void gettable()
{
        for(int i=0;i<=49;i++)
                num095[i]=pow(0.95,i);
}
bool cmp(int a,int b)
{
        return a>b;
}
int main()
{
        int t;
        scanf("%d",&t);
        gettable();
        while(t--)
        {
                int n;
                scanf("%d",&n);
                for(int i=1;i<=n;i++)
                        scanf("%d",&a[i]);
                sort(a+1,a+n+1,cmp);
                double sum=0;
                for(int i=1;i<=n;i++)
                        sum+=a[i]*1.0000*num095[i-1];
                printf("%lf\n",sum);
        }
        return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值