hihoCoder 1237 Farthest Point

#1237 : Farthest Point

时间限制: 5000ms
单点时限: 1000ms
内存限制: 256MB

描述

Given a circle on a two-dimentional plane.

Output the integral point in or on the boundary of the circle which has the largest distance from the center.

输入

One line with three floats which are all accurate to three decimal places, indicating the coordinates of the center x, y and the radius r.

For 80% of the data: |x|,|y|<=1000, 1<=r<=1000

For 100% of the data: |x|,|y|<=100000, 1<=r<=100000

输出

One line with two integers separated by one space, indicating the answer.

If there are multiple answers, print the one with the largest x-coordinate.

If there are still multiple answers, print the one with the largest y-coordinate.


样例输入
1.000 1.000 5.000
样例输出
6 1


微软2016计试题目。计算几何题。其实也算机智题吧。

题目大意是:在二维平面直角坐标系里,给出圆心和半径,在这个圆内核圆上,找一个点,使得这个点到坐标原点的距离最大,相同最大取X最大,再相同取Y最大。

其实就是枚举。一开始想先确定满足极值的小范围,然后再这个范围里枚举点。后来看了看复杂度和时间限制。发现直接暴力枚举X就行了。根据X算出两个Y,然后根据解的优先取就可以了。


一开始圆心Y坐标设变量y0,交上去的时候编译报错。貌似和头文件里有重变量。下次注意啊。

#include <stdio.h>
#include <math.h>
double x0,yo,r;
int main()
{
        while(scanf("%lf%lf%lf",&x0,&yo,&r)>0)
        {
            int maxx=floor(x0+r);
            int minx=ceil(x0-r);
            int ansx=0,ansy=0;
            double dis=0;
            for(int x=minx;x<=maxx;x++)
            {
                int y=floor(yo+sqrt(r*r-(x*1.000-x0)*(x*1.000-x0)));
                if(sqrt((x*1.000-x0)*(x*1.000-x0)+(y*1.000-yo)*(y*1.000-yo))>dis||(sqrt((x*1.000-x0)*(x*1.000-x0)+(y*1.000-yo)*(y*1.000-yo))==dis&&((x>ansx||(x==ansx&&y>ansy)))))
                    ansx=x,ansy=y,dis=sqrt((x*1.000-x0)*(x*1.000-x0)+(y*1.000-yo)*(y*1.000-yo));
                y=ceil(yo-sqrt(r*r-(x*1.000-x0)*(x*1.000-x0)));
                if(sqrt((x*1.000-x0)*(x*1.000-x0)+(y*1.000-yo)*(y*1.000-yo))>dis||(sqrt((x*1.000-x0)*(x*1.000-x0)+(y*1.000-yo)*(y*1.000-yo))==dis&&((x>ansx||(x==ansx&&y>ansy)))))
                    ansx=x,ansy=y,dis=(sqrt((x*1.000-x0)*(x*1.000-x0)+(y*1.000-yo)*(y*1.000-yo)));

            }
            printf("%d %d\n",ansx,ansy);
        }
    }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值