CSU 1683 Cryptographer’s Conundru

1683: Cryptographer’s Conundrum

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 97   Solved: 72
[ Submit][ Status][ Web Board]

Description

Input

Output

Sample Input

SECRET

Sample Output

4

HINT

Source


前面说了那么多,都没什么用,就是问把输入的字符串变成PER循环型的,需要几步。

水题。



#include <stdio.h>
#include <string.h>
const int MAXN=305;
char str[MAXN];
int main()
{
        while(scanf("%s",str)>0)
        {
                int ans=0;
                for(int j=0;j<strlen(str);j++)
                        if(((j+1)%3==1&&str[j]!='P')||((j+1)%3==2&&str[j]!='E')||((j+1)%3==0&&str[j]!='R'))
                                ans++;
                printf("%d\n",ans);
        }
        return 0;
}
 
/**************************************************************
    Problem: 1683
    User: 0905130123
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:960 kb
****************************************************************/



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值