Sicily 1002

DFS,自己不会做T T 百度了一下 学了一下。所以应该不能算上是自己完成的。。看了下别人的代码然后自己也跟着写了一下,话说题目范围1000,然后数组开1000我WA,换成1010才可以。

题目:

Description

Given a sequence of consecutive integers n,n+1,n+2,...,m, an anti-prime sequence is a rearrangement of these integers so that each adjacent pair of integers sums to a composite (non-prime) number. For example, if n = 1 and m = 10, one such anti-prime sequence is 1,3,5,4,2,6,9,7,8,10. This is also the lexicographically first such sequence. We can extend the definition by defining a degree danti-prime sequence as one where all consecutive subsequences of length 2,3,...,d sum to a composite number. The sequence above is a degree 2 anti-prime sequence, but not a degree 3, since the subsequence 5, 4, 2 sums to 11. The lexicographically .rst degree 3 anti-prime sequence for these numbers is 1,3,5,4,6,2,10,8,7,9.

Input

Input will consist of multiple input sets. Each set will consist of three integers, n, m, and d on a single line. The values of n, m and d will satisfy 1 <= n < m <= 1000, and 2 <= d <= 10. The line 0 0 0 will indicate end of input and should not be processed.

Output

For each input set, output a single line consisting of a comma-separated list of integers forming a degree danti-prime sequence (do not insert any spaces and do not split the output over multiple lines). In the case where more than one anti-prime sequence exists, print the lexicographically first one (i.e., output the one with the lowest first value; in case of a tie, the lowest second value, etc.). In the case where no anti-prime sequence exists, output No anti-prime sequence exists.

Sample Input

1 10 2
1 10 3
1 10 5
40 60 7
0 0 0

Sample Output

1,3,5,4,2,6,9,7,8,10
1,3,5,4,6,2,10,8,7,9
No anti-prime sequence exists.
40,41,43,42,44,46,45,47,48,50,55,53,52,60,56,49,51,59,58,57,54

解法:

// Copyright <lijiancheng> [2014]
// Sicily 1002
#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;

int n,m,d;
bool flag;
int used[1010];
int arr[1010];

// true means is a prime number
bool is_prime(int a) {
	for (int i = 2; i * i <= a; i++) {
		if (a % i == 0) return false;
	}
	return true;
}

bool can_put(int pos, int val) {
	for (int i = pos-1; i >= 0 && i >= pos-d+1; i--) {
		val += arr[i];
		if (is_prime(val)) return false;
	}
	return true;
}

void dfs(int pos) {
	// begin n to m, put i in pos
	for (int i = n; i <= m; i++ ) {
		if(!used[i] && can_put(pos, i)) {
			used[i] = 1;
			arr[pos] = i;
			// if the current pos is the lase one, then flag = 1 and return
			if (pos == m-n) {
				flag = true;
				return;
			}
			// continue to put
			dfs(pos + 1);
			if (flag) return;
			// if flag can't be true , then the i is in wrong place
			used[i] = 0;
		}
	}
}


int main() {
	while (cin >> n >> m >> d && n && m && d) {
		memset(used, 0, sizeof(used));
		flag = false;
		dfs(0); // start in the 0 position
		if(flag)
        {
            printf("%d",arr[0]);
            for(int i=1;i<=m-n;++i)
                printf(",%d",arr[i]);
            printf("\n");
        }
        else
            printf("No anti-prime sequence exists.\n");
	}
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值