HDOJ Bone Collector (0/1背包)

     

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14
 

Author
Teddy

 

          0/1 背包的典型应用,不过对于数据还是要注意点,因为骨头的体积可以是零。


           具体的状态转移方程:

                            f [ i ][ v ] = max ( f[ i - 1] [ v - v[ i ] ] + w[ i ], f[ i - 1] [ v ])

           也可以用一维数组

                           f[ v ] = max( f[ v ], f[v - v[ i ]] + w[ i ])

           一维的要从v -> 0 循环,二维的就是 0 -> v循环


         然后注意下menset  就差不多了。  


           最近开始狠抓 dp  所以 一步一步的努力学好,一点一点积累 加油!


   贴个二维代码  :

#include <stdio.h>
#include <string.h>
#define N 1010

int dp[N][N];
int value[N];
int V[N];

int max(int a,int b){
    return a > b ? a : b;
}

int main()
{
    int i,n,v,t,j;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&v);

        for(i = 1; i <= n; i++){
            scanf("%d",&value[i]);
        }
        for(i = 1; i <= n; i++){
            scanf("%d",&V[i]);
        }
        memset(dp,0,sizeof(dp));

        for(i = 1; i <= n; i++){
            for(j = 0; j <= v ; j++){
                if(j >= V[i])
                dp[i][j] = max(dp[i - 1][ j - V[i]] + value[i],dp[i-1][j]);
                else
                dp[i][j] = dp[i - 1][j];
            }
        }


        printf("%d\n",dp[n][v]);
    }
    return 0;
}


一维代码:

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <map>
#include <set>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>

using namespace std;

#define mst(a,b) memset(a,b,sizeof(a))
#define eps 10e-8

const int MAX_ = 1010;
const int N = 100010;
const int INF = 0x7fffffff;

struct node{
    int value, v;
}a[MAX_];

int dp[MAX_];
int n, m;

int main(){
    int s, t, v, T;
    scanf("%d",&T);
	while(T--){
	    scanf("%d%d",&n,&m);
	    mst(dp,0);
	    for(int i = 1; i <= n; ++i){
            scanf("%d",&a[i].value);
	    }

        for(int i = 1; i <= n; ++i){
            scanf("%d",&a[i].v);
	    }

	    for(int i = 1; i <= n; ++i){
            for(int j = m; j >= a[i].v; --j){
                dp[j] = max(dp[j], dp[j - a[i].v] + a[i].value);
            }
	    }

        printf("%d\n",dp[m]);
	}
	return 0;
}

(2014.4.22)


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
自动控制节水灌溉技术的高低代表着农业现代化的发展状况,灌溉系统自动化水平较低是制约我国高效农业发展的主要原因。本文就此问题研究了单片机控制的滴灌节水灌溉系统,该系统可对不同土壤的湿度进行监控,并按照作物对土壤湿度的要求进行适时、适量灌水,其核心是单片机和PC机构成的控制部分,主要对土壤湿度与灌水量之间的关系、灌溉控制技术及设备系统的硬件、软件编程各个部分进行了深入的研究。 单片机控制部分采用上下位机的形式。下位机硬件部分选用AT89C51单片机为核心,主要由土壤湿度传感器,信号处理电路,显示电路,输出控制电路,故障报警电路等组成,软件选用汇编语言编程。上位机选用586型以上PC机,通过MAX232芯片实现同下位机的电平转换功能,上下位机之间通过串行通信方式进行数据的双向传输,软件选用VB高级编程语言以建立友好的人机界面。系统主要具有以下功能:可在PC机提供的人机对话界面上设置作物要求的土壤湿度相关参数;单片机可将土壤湿度传感器检测到的土壤湿度模拟量转换成数字量,显示于LED显示器上,同时单片机可采用串行通信方式将此湿度值传输到PC机上;PC机通过其内设程序计算出所需的灌水量和灌水时间,且显示于界面上,并将有关的灌水信息反馈给单片机,若需灌水,则单片机系统启动鸣音报警,发出灌水信号,并经放大驱动设备,开启电磁阀进行倒计时定时灌水,若不需灌水,即PC机上显示的灌水量和灌水时间均为0,系统不进行灌水。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值