HDU 2693 Bone Collector II


Problem Description

The title of this problem is familiar,isn't it?yeah,if you had took part in the "Rookie Cup" competition,you must have seem this title.If you haven't seen it before,it doesn't matter,I will give you a link:

Here is the link: http://acm.hdu.edu.cn/showproblem.php?pid=2602

Today we are not desiring the maximum value of bones,but the K-th maximum value of the bones.NOTICE that,we considerate two ways that get the same value of bones are the same.That means,it will be a strictly decreasing sequence from the 1st maximum , 2nd maximum .. to the K-th maximum.

If the total number of different values is less than K,just ouput 0.

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, K(N <= 100 , V <= 1000 , K <= 30)representing the number of bones and the volume of his bag and the K we need. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the K-th maximum of the total value (this number will be less than 2 31).

Sample Input

3
5 10 2
1 2 3 4 5
5 4 3 2 1
5 10 12
1 2 3 4 5
5 4 3 2 1
5 10 16
1 2 3 4 5
5 4 3 2 1

Sample Output

12
2
0

记录前k大的最优值,即p[v][k]表示装了v体积的东西获得第k大的价值
多开两个数组a[], b[]来保存 p[j - w[i]][1 -> k] + v[i] , 以及p[j][1 - >k] 这些值
然后将两个数组里面的值按大到小的顺序重新写入 p[j][1 -k]中

#include <iostream>
#include <string.h>
#define N 110
#define V 1010
using namespace std;
int t,n,v,k,p[V][N],a[N],i,j,b[N],va[N],vo[N];
int d;
int x,y,z;
int main()
{
    cin>>t;
    while(t--)
    {
        memset(p,0,sizeof(p));
        memset(a,-1,sizeof(a));
        memset(b,-1,sizeof(b));
        cin>>n>>v>>k;
        for (i=1; i<=n; i++)
            cin>>va[i];
        for (i=1; i<=n; i++)
            cin>>vo[i];
        a[0]=b[0]=1;
        for(i=1; i<=n;i++)
        {
            for(j=v; j>=vo[i]; j--)
            {
                for (d=1; d<=k; d++)
                {
                    a[d]=p[j-vo[i]][d]+va[i];
                    b[d]=p[j][d];
                }
                x=y=z=1;
                while(z<=k&&(x<=k||y<=k))
                {
                    if(a[x]>b[y])
                        p[j][z]=a[x++];
                    else
                        p[j][z]=b[y++];
                    if (p[j][z]!=p[j][z-1])
                        z++;
                }
            }
        }

        cout<<p[v][k]<<endl;
    }
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值