Rightmost Digit

Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9245 Accepted Submission(s): 2327
 
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 
Output
For each test case, you should output the rightmost digit of N^N.
 
Sample Input
2
3
4
 
Sample Output
7
6


      
      
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
#include<stdio.h>
main()
{
    int n,cas,m;
    scanf("%d",&cas);
    while(cas--)
    {
        scanf("%d",&n);
        m=n%10;
        if(m==0||m==1||m==5||m==6)
            printf("%d\n",m);
        if(m==2)
        {
            if (n%4==1) printf("2\n");
            if (n%4==2) printf("4\n");
            if (n%4==3) printf("8\n");
            if (n%4==0) printf("6\n");
        }
        if(m==3)
        {
            if (n%4==1) printf("3\n");
            if (n%4==2) printf("9\n");
            if (n%4==3) printf("7\n");
            if (n%4==0) printf("1\n");
        }
        if(m==7)
        {
            if (n%4==1) printf("7\n");
            if (n%4==2) printf("9\n");
            if (n%4==3) printf("3\n");
            if (n%4==0) printf("1\n");
        }
        if(m==8)
        {
            if (n%4==1) printf("8\n");
            if (n%4==2) printf("4\n");
            if (n%4==3) printf("2\n");
            if (n%4==0) printf("6\n");
        }
        if (m==4)
        {
            if (n%2==1) printf("4\n");
            if (n%2==0) printf("6\n");
        }
        if (m==9)
        {
            if (n%2==1) printf("9\n");
            if (n%2==0) printf("1\n");
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值