杨辉三角

杨辉三角

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 67572    Accepted Submission(s): 27943


Problem Description
还记得中学时候学过的杨辉三角吗?具体的定义这里不再描述,你可以参考以下的图形:
1
1 1
1 2 1
1 3 3 1
1 4 6 4 1
1 5 10 10 5 1
 

Input
输入数据包含多个测试实例,每个测试实例的输入只包含一个正整数n(1<=n<=30),表示将要输出的杨辉三角的层数。
 

Output
对应于每一个输入,请输出相应层数的杨辉三角,每一层的整数之间用一个空格隔开,每一个杨辉三角后面加一个空行。
 

Sample Input
  
  
2 3
 

Sample Output
  
  
1 1 1 1 1 1 1 2 1
 

Author
lcy
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1000  2048  2046  1096  2049 
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include <set>
#include<algorithm>
#include <limits.h>
#include <ctype.h>
#include <map>
#include <stack>
#include <sstream>
typedef long long LL;
using namespace std;
const int N = 105;
int data[N][N];
int dp[N][N];
char c[100][100] = {' '};
#define PI 3.1415926
void fun() {
    data[0][0] = 1;
    data[1][0] = 1;
    data[1][1] = 1;
    for(int i = 2; i <= 30; i++) {
        for(int j = 0; j <= i; j++) {
            if(j == 0 || j == i) data[i][j] = 1;
            else data[i][j] = data[i - 1][j - 1] + data[i - 1][j];
        }
    }
//    for(int i = 0; i <= 30; i++){
//        for(int j = 0; j <= i; j++){
//            cout << data[i][j] << " ";
//        }
//        cout << endl;
//    }
}
int main() {
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int n;
    fun();
    int flag = 0;
    while(scanf("%d", &n) != EOF) {
        //if(flag) cout << endl;
        for(int i = 0; i < n; i++) {
            for(int j = 0; j <= i; j++) {
                if(j == 0) cout << data[i][j] ;
                else cout << " "<< data[i][j] ;
            }
            cout << endl;
        }
        cout << endl;
        flag = 1;
    }


    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值