夹角有多大II

夹角有多大II

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11539    Accepted Submission(s): 5983


Problem Description
这次xhd面临的问题是这样的:在一个平面内有两个点,求两个点分别和原点的连线的夹角的大小。

注:夹角的范围[0,180],两个点不会在圆心出现。
 

Input
输入数据的第一行是一个数据T,表示有T组数据。
每组数据有四个实数x1,y1,x2,y2分别表示两个点的坐标,这些实数的范围是[-10000,10000]。
 

Output
对于每组输入数据,输出夹角的大小精确到小数点后两位。
 

Sample Input
  
  
2 1 1 2 2 1 1 1 0
 

Sample Output
  
  
0.00 45.00
 

Author
xhd
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2076  2079  2082  2093  2077 
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include <set>
#include<algorithm>
#include <limits.h>
#include <ctype.h>
#include <map>
#include <stack>
#include <sstream>
typedef long long LL;
using namespace std;
const int N = 105;
int data[N][N];
int dp[N][N];
char c[100][100] = {' '};
#define PI 3.1415926
int main() {
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    int T;
    cin >> T;
    double x1, y1, x2, y2;
    while(T--){
        //if(n == 0 && m== 0) break;
        scanf("%lf %lf %lf %lf", &x1, &y1, &x2, &y2);
        double a = sqrt(x1 * x1 + y1 * y1);
        double b = sqrt(x2 * x2 + y2 * y2);
        double c = sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2));
        double cos = (a * a + b * b - c * c) / (2 * a * b);
        double res = acos(cos) * 180 / PI;
        if(res > 180){
            res -= 180;
        }
        printf("%.2lf\n", res);
    }


    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值