BigNums——HDUOJ 1002 - A + B Problem II

原题

  • Problem Description

    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

  • Input

    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

  • Output

    For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

  • Sample Input

    2
    1 2
    112233445566778899 998877665544332211

  • Sample Output

    Case 1:
    1 + 2 = 3

    Case 2:
    112233445566778899 + 998877665544332211 = 1111111111111111110

解题思路:

  1. 定义两个字符数组来保存按字符输入的两个加数。
  2. 使字符串的中的字符数字减去’0’,再将两个数字加上进位的数字>=10的可以使本位减10,下一位自增1。
  3. 最后就是格式控制好输出。

代码:

#include<stdio.h>
#include <string.h>
char a[1001], b[1001];
int sum[1001];
void BigNumberAdd(int len1,int len2)
{
    int j = len1 - 1;
    int k = len2 - 1;
    int sumIndex = 0;
    while (j >= 0 && k >= 0)
    {
        if ((sum[sumIndex] + (a[j] - '0') + (b[k] - '0')) >= 10)    //字符,通过ASCII码,减去'0'得到字符对应的数字
        {
            sum[sumIndex] = (sum[sumIndex] + (a[j] - '0') + (b[k] - '0')) - 10; //最大数:19
            sum[sumIndex + 1]++;
        }else
        {
            sum[sumIndex] = (sum[sumIndex] + (a[j] - '0') + (b[k] - '0'));  //最大数:9
        }
        sumIndex++;
        j--;k--;
    }
    if (j >= 0)
    {
        for (;j >=0; j--)
        {
            if ((sum[sumIndex] + (a[j] - '0')) >= 10)
            {
                sum[sumIndex] = (sum[sumIndex] + (a[j] - '0')) - 10;
                sum[sumIndex + 1]++;
            }
            else
            {
                sum[sumIndex] = sum[sumIndex] + (a[j] - '0');
            }
            sumIndex++;
        }
    }else if (k >= 0)
    {
        for (;k >= 0; k--)
        {
            if ((sum[sumIndex] + (b[k] - '0')) >= 10)
            {
                sum[sumIndex] = (sum[sumIndex] + (b[k] - '0')) - 10;
                sum[sumIndex + 1]++;
            }
            else
            {
                sum[sumIndex] = sum[sumIndex] + (b[k] - '0');
            }
            sumIndex++;
        }
    }
    if (sum[sumIndex] == 0)
    {
        sumIndex--;         //将sumIndex定位到最高位
    }
    int t;
    for (t = sumIndex; t >= 0; t--) //输出结果
        printf("%d", sum[t]);
    printf("\n");
}

int main()
{
    int AllCount = 0;
    int len1, len2;
    scanf("%d", &AllCount);
    int i = 1;
    for(;i <= AllCount; i++)
    {
        memset(sum, 0, sizeof(sum));    //menset()将数组sum[1001]全部置零
        memset(a, '\0', sizeof(a));
        memset(b, '\0', sizeof(b));

        scanf("%s", &a);        ///空格和换行则判为结束;gets()则遇换行结束。
        scanf("%s", &b);
        len1 = strlen(a);       //两个字符串的长度
        len2 = strlen(b);

        printf("Case %d:\n", i);
        printf("%s + %s = ", a, b);

        BigNumberAdd(len1, len2);       //输出结果

        if (i != AllCount)
            printf("\n");
    }
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值