Deepest Root(dfs深度优先遍历)

Deepest Root

题目

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤104​​ ) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N−1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:
For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

答案

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int n;
int vis[10005],l[10005];
vector<int> vec[10005];
int dfs(int root,int level)
{
	vis[root]=1;
	int max=level;
	for(int i=0;i<vec[root].size();i++)
	{
		if(!vis[vec[root][i]]) 
		{
			int tmp=dfs(vec[root][i],level+1);
			if(tmp>max) max=tmp;
		}
	}
	return max;
}
int main()
{
	cin>>n;
	if(n==1) 
	{
		cout<<1<<endl;
		return 0;
	}
	for(int i=0;i<n-1;i++)
	{
		int x,y;
		cin>>x>>y;
		vec[x].push_back(y);
		vec[y].push_back(x);
	}
	
	for(int i=1;i<=n;i++)
	{
		fill(vis,vis+10005,0);
		int count=0;
		l[i]=dfs(i,1);
		count++;
		for(int j=1;j<=n;j++)
		{
			
			if(!vis[j])
			{
				int tmp = dfs(j,1);
				count++;
			}
		}
		if(count>1)
		{
			printf("Error: %d components",count);
			return 0;
		}
	}
	int max=*max_element(l,l+n);
	for(int i=1;i<=n;i++)
	{
		if(l[i]==max) cout<<i<<endl;
	}	
}

注意

  1. 本题使用二位数组会内存超限,所以要采用vector
  2. 注意n=1情况的处理
  • 2
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 13
    评论
评论 13
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值