acm 1006 电梯移动时间问题

1.1006

2.Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.


Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed. 
 
Output
Print the total time on a single line for each test case. 
 
Sample Input
1 2
3 2 3 1
0
 
sample Output
17
41

3.电梯上移花6秒,电梯下移花4秒,每层停留5秒钟,采用循环体输入电梯层数,比较原始层数,求出时间总和,最后将此时的层数变为下一次比较的初始层

4.本题思路清晰,用时较短,ac时并无太大障碍*-*

5.

#include<iostream>

#include<algorithm>

using namespacestd;

int main()

{   int n,i,a,b,sum;

    while(cin>>n&&n!=0)

    {  sum=0;

           b=0;

        for(i=0;i<n;i++)

        {  cin>>a;

            if(a>b) sum=sum+(a-b)*6+5;

            else {if(a<b)sum=sum+4*(b-a)+5;

                        else sum=sum+5;}

           b=a;

           }

        cout<<sum<<endl;

    }

    return 0;

}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值