acm 1005 纸币问题

1.1005

2.

Problem Description
"Yakexi, this is the best age!" Dong MW works hard and get high pay, he has many 1 Jiao and 5 Jiao banknotes(纸币), some day he went to a bank and changes part of his money into 1 Yuan, 5 Yuan, 10 Yuan.(1 Yuan = 10 Jiao)
"Thanks to the best age, I can buy many things!" Now Dong MW has a book to buy, it costs P Jiao. He wonders how many banknotes at least,and how many banknotes at most he can use to buy this nice book. Dong MW is a bit strange, he doesn't like to get the change, that is, he will give the bookseller exactly P Jiao.

Input
T(T<=100) in the first line, indicating the case number. T lines with 6 integers each: P a1 a5 a10 a50 a100 ai means number of i-Jiao banknotes. All integers are smaller than 1000000.

Output
Two integers A,B for each case, A is the fewest number of banknotes to buy the book exactly, and B is the largest number to buy exactly.If Dong MW can't buy the book with no change, output "-1 -1".

Sample Input
  
  
3 33 6 6 6 6 6 10 10 10 10 10 10 11 0 1 20 20 20

Sample Output
  
  
6 9 1 10 -1 -1

3.有五种钱币的数量:1,5,10,50,100,要求找出钱数固定的两种方案,一种数量最多,一种数量最少

4.手上所有的纸币价格为a,书的钱数为b,花费后的钱数为(a-b),我们可以用最少的纸币去凑(a-b),相减可得剩余最多

5.

#include<cstdio>

#include<iostream>

#include<stdio.h>

#include<vector>

#include<algorithm>

#include<numeric>

#include<math.h>

#include<string.h>

#include<map>

#include<set>

#include<vector>

using namespacestd;

int themin(intp,int arr[],int a[])

{

    int count=0,i,k;

    for(i=4;i>=0;i--)

    {

        if(p>=arr[i]*a[i])

        {

            p-=arr[i]*a[i];

            count+=arr[i];

        }

        else

        {

            k=p/a[i];

            count+=k;

            p-=k*a[i];

        }

    }

    if(p>0) return -1;

    else return count;

}

int themax(intp,int arr[],int a[])

{

    int sum[10],i,count=0;

    sum[0]=arr[0];

    for(i=1;i<=4;i++)

        sum[i]=sum[i-1]+a[i]*arr[i];

 

    for(i=4;i>0;i--)

    {

        if(p<=sum[i-1]) continue;

        else

        {

            int t;

           t=((p-sum[i-1])/a[i])+(((p-sum[i-1])%a[i])?1:0);

            count+=t;

            p-=t*a[i];

        }

    }

    if(p>arr[0])    return -1;

    else   return count+p;

}

 

 

int main()

{   int N,i,t;

    cin>>N;

    int p,a[6]={1,5,10,50,100},arr[6];

    while(N--)

    {

        cin>>p;int sum=0;

        for(i=0;i<5;i++)

        {

            cin>>arr[i];

            sum+=arr[i]*a[i];

        }

        if(sum<p)cout<<-1<<" "<<-1<<endl;

        else

        {

            t=themin(p,arr,a);

            if(t==-1)

            {

                cout<<-1<<""<<-1<<endl;

            }

            else

            {

                cout<<t<<""<<themax(p,arr,a)<<endl;

            }

        }

    }

      return 0;

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值