acm 1017 装箱问题

1.1017

2.

Problem Description
A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input
The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output
The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last ``null'' line of the input file.

Sample Input
  
  
0 0 4 0 0 1 7 5 1 0 0 0 0 0 0 0 0 0

Sample Output
  
  
2 1

3.装箱问题(贪心)从最大的开始,即6*6 5*5 4*4每个要一个箱子
5×5+11个1×1,4×4+5个2×2
3×3的分4种情况
1.正好装满
2.余一个,则装5个2×2的,7个1×1的
3.余两个,则装3个2×2,6个1×1的
4.余三个,则装1个2×2的,5个1×1的
还要多余的2×2的,装完后用1×1的填充
若2×2的不够,原来用2×2的用1×1的填充

4.参照唧唧歪歪日志,装箱问题一般用贪心思路

5.

#include<iostream>
#include<cstdio>
using namespace std;  
int main()
{
 int p[4]={0,5,3,1},a[10];  //3×3的放完后,余下的放入新箱子后,还可以放几个2×2的包裹(下标对应余数)
 while(1)
 {
  int sum=0;
  for(int i=1;i<=6;i++)
  {
   scanf("%d",&a[i]);
   sum+=a[i];
  }
  if(sum==0)
   break;
  sum=0;
  sum=a[4]+a[5]+a[6]+(a[3]+3)/4;      //6*6,5*5,4*4每个都要用一个箱子(画图),3×3的对4向上取整
  int need2=a[4]*5+p[a[3]%4];         //需要的2×2的个数
  if(need2<a[2])                      //上取整
   sum+=(a[2]-need2+8)/9;          
  int need1=sum*36-a[2]*4-a[3]*9-a[4]*16-a[5]*25-a[6]*36;   //需要的1×1的个数,即所有箱子的总面积减去后5种盒子的总面积 
  if(need1<a[1])                                            
   sum+=(a[1]-need1+35)/36;        //上取整
  printf("%d\n",sum);
 }
 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值