acm 2 1014(同1013) A strange lift

1.1013

2.

Problem Description
There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button "UP" , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button "DOWN" , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can't go up high than N,and can't go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button "UP", and you'll go up to the 4 th floor,and if you press the button "DOWN", the lift can't do it, because it can't go down to the -2 th floor,as you know ,the -2 th floor isn't exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button "UP" or "DOWN"?
 
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,....kn.
A single 0 indicate the end of the input.
 
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can't reach floor B,printf "-1".
 
Sample Input
   
   
5 1 5 3 3 1 2 5 0
 Sample Output
   
   
3

3.电梯每层有一个数字,每个数字不相同,若第n层有个数字k,那么这一层只能上k层或下k层,当然了不能低于1层或高于n层,给定起点与终点,求出最少要按几次键

4.这道题用搜索的思想可以做出,广度搜索

5.#include<iostream>
#include<string.h>
#include<set>
#include<stdio.h>
#include<vector>
#include<algorithm>
#include<numeric>
#include<math.h>
#include<string.h>
#include<sstream>
#include<stdio.h>
#include<string>
#include<cstdlib>
#include<algorithm>
#include<iostream>
#include<queue>
#include<queue>
#include<iomanip>
#include<cstdio>
using namespace std;
struct node
{
   int x ;
   int t ;
}n1,n2,m;
int c[2000],ww[2000];  
int flag ;                 
int n , a , b ;        
int main(  )
{
    while( scanf("%d" , &n ) , n )
    {
       if( n== 0 ) break ;      
       cin>>a>>b;
       for( int i= 1;  i<= n ; i++ )     
       { cin>>ww[i] ; c[i] = 0 ; }
       flag = 0 ;                      //初始为0
       n1.x = a ; n1.t = 0 ;        //把a开始所在楼层赋给结构体, 所走步数为0
       queue<node>Q;              
       Q.push(n1);                        
       c[n1.x] = 1 ;          
       while( !Q.empty() )       
       {
          m = Q.front() ;          
          Q.pop();                  
          if( m.x == b )         
          { flag = 1 ; break ; }
          n1.x = m.x - ww[m.x];  
          n2.x = m.x + ww[m.x]; 
          if( n1.x>0 && n1.x<= b && !c[n1.x] )
          {
                n1.t = m.t + 1 ;       
                c[n1.x] = 1 ;     
                Q.push(n1);
              }
            if( n2.x>0 && n2.x<= b && !c[n2.x] )
             {
                n2.t = m.t+1 ;
                c[n2.x] = 1 ;
                Q.push(n2);
             }
       }
       if( flag ) cout<<m.t<<endl;
       else cout<<"-1"<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值