acm 3 1015 十进制转换

1.1015

2.Problem Description
Give you a number on base ten,you should output it on base two.(0 &lt; n &lt; 1000)(0<n<1000)
 
Input
For each case there is a postive number n on base ten, end of file.
 
Output
For each case output a number on base two.
 
Sample Input
1
2


Sample Output
1
10
11

3.十进制转换成二进制

4.题中的n除以2,取出余数,输出每一步的余数,除到1时存入1,结束

5.#include <iostream>
#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int main()
{
     int a,i,j;
    int arr[100005];
    while(cin>>a)
    {
        i=0;
        while(a!=0)
        {
            arr[i]=a%2;
            a/=2;
            i++;
        }
        for(i--;i>=0;i--)
            cout<<arr[i];
        cout<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值