简单的数论题目zju1652(不知道有没有AC,因为我在zju上没帐号)PKU上没有

代码是在新校区机房写的,关键是找出递归公式!

/*
Count the Regions

--------------------------------------------------------------------------------

Time limit: 1 Seconds   Memory limit: 32768K  
Total Submit: 318   Accepted Submit: 207  

--------------------------------------------------------------------------------

What's the maximum number of regions definable by N zig-zag lines, each of which consists of two parallel infinite half-lines joined by a straight line segment?

Here is an example of 2 zig-zag lines yield 12 regions at the most.

 


Input

The input consists of a sequence of N (<= 10000), which is the number of the zig-zag lines, one per line.


Output

For each N, you should output the number of the maximum regions.


Sample Input

1
2
Sample Output

2
12

*/
#include "stdio.h"
#include "vector"

using namespace std;

int main()
{
 int n,i,j;
 vector<int> p;
 scanf("%d",&n);
 if(n<0||n>10000)
  return 0;
 p.push_back(2);
 for(i=1;i<n;i++){
  j=p.back()+9*i+1;
  p.pop_back();
  p.push_back(j);
 }
 j=p.back();
 printf("%d/n",j);
 return 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值