hdu-Play on Words

Some of the secret doors contain a very interesting word puzzle. The team of archaeologists has to solve it to open that doors. Because there is no other way to open the doors, the puzzle is very important for us.

There is a large number of magnetic plates on every door. Every plate has one word written on it. The plates must be arranged into a sequence in such a way that every word begins with the same letter as the previous word ends. For example, the word acm'' can be followed by the wordmotorola’’. Your task is to write a computer program that will read the list of words and determine whether it is possible to arrange all of the plates in a sequence (according to the given rule) and consequently to open the door.
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing a single integer number Nthat indicates the number of plates (1 <= N <= 100000). Then exactly Nlines follow, each containing a single word. Each word contains at least two and at most 1000 lowercase characters, that means only letters ‘a’ through ‘z’ will appear in the word. The same word may appear several times in the list.
Output
Your program has to determine whether it is possible to arrange all the plates in a sequence such that the first letter of each word is equal to the last letter of the previous word. All the plates from the list must be used, each exactly once. The words mentioned several times must be used that number of times.
If there exists such an ordering of plates, your program should print the sentence “Ordering is possible.”. Otherwise, output the sentence “The door cannot be opened.”.
Sample Input

3
2
acm
ibm
3
acm
malform
mouse
2
ok
ok

Sample Output

The door cannot be opened.
Ordering is possible.
The door cannot be opened.

代码分析:注意欧拉路径出入度之差为1,中间为0,所以整体之和为0或者2.
AC代码:

//hdu-Play on Words
#include<bits/stdc++.h>
using namespace std;
int ba[30],tot,degin[30],degout[30];
int look[26];
void init(int n){
 for(int i=0;i<n;i++){
 	memset(degin,0,sizeof(degin));
 	memset(degout,0,sizeof(degout));
 	memset(look,0,sizeof(look));
 	ba[i]=i;
 }
 tot=1;
}
int fson(int a){
 while(a!=ba[a])
 	a=ba[a];
 return a;
}
void uson(int a,int b){
 int fa=fson(a);
 int fb=fson(b);
 if(fa!=fb){
 	ba[fb]=fa;
 	tot++;	
 }
}
int main(){
 //freopen("1.txt","r",stdin);
 int t;
 cin>>t;
 cin.ignore();
 string s;
 int n;
 while(t--){
 	cin>>n;
 	init(28);//将单词的每个字母看成节点
 	for(int i=0;i<n;i++){
 		cin>>s;
 		int u=s[0]-'a';
 		int v=s[s.size()-1]-'a';
 		++degin[u];
 		++degout[v];
 		look[u]=look[v]=1;//此时表示已经访问了某个字母 
 		uson(u,v);//判断每个字符是不是同一个句子 
 	} 
 	int res=0,count=0;
 	//如果已经访问了 ,统计访问的字母个数,也就是节点的个数
 	 for(int i=0;i<26;i++) count+=look[i];
 	 if(tot==count){
 	 	//如果此时已经遍历完所有的节点
 		 int tmp=0;
 		 for(int i=0;i<26;i++)
 		 	tmp+=abs(degin[i]-degout[i]);//欧拉路径度数之和只有0 1 2之差 
 		 if(tmp==0||tmp==2)
 		 	res=true;
 	 } 
 	 if(res) printf("Ordering is possible.\n");
 	 else printf("The door cannot be opened.\n") ;
 }
 return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值