USACO--Dual Palindromes

Dual Palindromes
Mario Cruz (Colombia) & Hugo Rickeboer (Argentina)

A number that reads the same from right to left as when read from left to right is called a palindrome. The number 12321 is a palindrome; the number 77778 is not. Of course, palindromes have neither leading nor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but the number 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

  • N (1 <= N <= 15)
  • S (0 < S < 10000)
and then finds and prints (in base 10) the first N numbers strictly greater than S that are palindromic when written in two or more number bases (2 <= base <= 10).

Solutions to this problem do not require manipulating integers larger than the standard 32 bits.

PROGRAM NAME: dualpal

INPUT FORMAT

A single line with space separated integers N and S.

SAMPLE INPUT (file dualpal.in)

3 25

OUTPUT FORMAT

N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listed in order from smallest to largest.

SAMPLE OUTPUT (file dualpal.out)

26
27
28

先说一下解体思路,我用得最简单方法,从输入的S+1开始,每次将这个数先转换进制,然后将进行转换后的数进行回文判断,如果回文超过两次,那么输入,S+1 again,再去转换,判断,直到输出满足条件的N个数为止,


代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#define maxn 15
using namespace std;

int dual(int* a,int len) //判断是否为回文数
{
	int fl=1;
	for(int i=0;i<=len;i++)
	{
		if(a[i]!=a[len]) {fl=0;break;}
		len--;
	}
	return fl;
}

int base_trans(int n,int* a,int base)  //进行进制转换,并求出转换后的数组长度
{
	int fl=0;
	while(n)
	{
		a[fl++]=n%base;
		n/=base;
	}
	return fl;
}

int main()
{
	freopen("dualpal.in","r",stdin);
	freopen("dualpal.out","w",stdout);

	int N,S,count=0;
	scanf("%d %d",&N,&S);
	for(int i=S+1;;i++)
	{
		int tr[maxn];//转换过进制的数
		int time=0; //统计回文次数
		for(int j=2;j<=10;j++)
		{
			memset(tr,0,sizeof(tr));
			int len=base_trans(i,tr,j);//进行进制转换,并求出转换后的长度

			if(dual(tr,len-1)) time++;  //如果当前进制是回文数,次数加以,然后进行下一进制转换
			if(time>=2) {printf("%d\n",i);count++;break;}//如果两次都是回文数,输出,count+1,然后进行下一个数
		}
		if(count>=N) break;  //输出够N个数了,就跳出
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值