UsacoTraining Chapter1.3 Dual Palindromes


Dual Palindromes
Mario Cruz (Colombia) & Hugo Rickeboer (Argentina)

A number that reads the same from right to left as when read fromleft to right is called a palindrome. The number 12321 is a palindrome;the number 77778 is not. Of course, palindromes have neither leadingnor trailing zeroes, so 0220 is not a palindrome.

The number 21 (base 10) is not palindrome in base 10, but thenumber 21 (base 10) is, in fact, a palindrome in base 2 (10101).

Write a program that reads two numbers (expressed in base 10):

  • N (1 <= N <= 15)
  • S (0 < S < 10000)
and then finds and prints (in base 10) the first N numbers strictlygreater than S that are palindromic when written in two or morenumber bases (2 <= base <= 10).

Solutions to this problem do not require manipulating integerslarger than the standard 32 bits.

PROGRAM NAME: dualpal

INPUT FORMAT

A single line with space separated integers N and S.

SAMPLE INPUT (file dualpal.in)

3 25

OUTPUT FORMAT

N lines, each with a base 10 number that is palindromic when expressed in at least two of the bases 2..10. The numbers should be listedin order from smallest to largest.

SAMPLE OUTPUT (file dualpal.out)

26
27
28
题意:从s开始,输出n个在2-10进制下是至少两个回文数的数字

题解:考虑极限数据,明显可以暴力穷举,所以上一题小小修改即可

另:英语真心重要啊,S that are palindromic when written in two or more number bases 我硬生生看成>=2的进制

/*
ID: nflsjxc1
TASK: dualpal
LANG: C++                 
*/
#include<bits/stdc++.h>

using namespace std;

int n,s;

char m[]={'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E','F','G','H','I','J','K','L','M','N'};

string change(int i,int b)
{
	stack<char>tmp;
	int t=i;
	while(i!=0)
	{
		tmp.push(m[i%b]);
		i/=b;
	}
	string ret="";
	while(!tmp.empty())
	{
		ret+=tmp.top();
		tmp.pop();
	}
	return ret;
}

bool spj(string str)
{
	if(str[0]=='0'||str[str.size()-1]=='0')return 1;
	else return 0;
}

bool hw(string str)
{
	if(spj(str))return 0;
	for(int i=0,j=str.size()-1;i<=j;i++,j--)
	{
		if(str[i]!=str[j])return 0;
	}
	return 1;
}

int main()
{
	freopen("dualpal.in","r",stdin);
	freopen("dualpal.out","w",stdout);
	ios::sync_with_stdio(0);

	cin>>n>>s;
	
	for(int i=s+1;;i++)
	{
		int cnt=0;
		for(int base=2;base<=10;base++)
		{
			if(hw(change(i,base)))
			{
				cnt++;
			}
			if(cnt==2)
			{
				cout<<i<<'\n';
				n--;
				if(n==0)return 0;
				break;
			}
		}
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值