USACO--Milking Cows

Milking Cows

Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).

Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):

  • The longest time interval at least one cow was milked.
  • The longest time interval (after milking starts) during which no cows were being milked.

PROGRAM NAME: milk2

INPUT FORMAT

Line 1:The single integer
Lines 2..N+1:Two non-negative integers less than 1,000,000, respectively the starting and ending time in seconds after 0500

SAMPLE INPUT (file milk2.in)

3
300 1000
700 1200
1500 2100

OUTPUT FORMAT

A single line with two integers that represent the longest continuous time of milking and the longest idle time.

SAMPLE OUTPUT (file milk2.out)

900 300

思路:

这道题挺简单的,刚开始的思路用的结构体排序,判断,要是下次开始时间小于上次结束时间,就更新连续的时间,如果下次开始时间大于上次结束时间,就求出间隔时间

可是这种思路一直没有解决 一组数据涵盖所有时间的情况,只有用这种笨方法,幸好数据不是太极端,否则肯定会超时。这种是开一个bool型大小为999999的数组,

把挤奶时间标记为true,间隔时间为false,这样来求出最大的连续,间隔时间


代码如下:

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#define MAXN 999999
using namespace std;

bool cmp(int a,int b)  
{
	return a>b;
}

int main()
{
	freopen("milk2.in","r",stdin);
	freopen("milk2.out","w",stdout);

	int N;
	scanf("%d",&N);
	int s,e,beg,fin,vis[MAXN];
	memset(vis,0,sizeof(vis));
	for(int i=0;i<N;i++)
	{
		scanf("%d%d",&s,&e);
		if(!i || s<beg) beg=s;       //beg为最早的开始时间
		if(!i || e>fin) fin=e;          //end为最后结束时间
		for(int j=s;j<e;j++)
			vis[j]=true;
	}

	int con,bre,len=0,arr[MAXN]; //con为连续的时间,bre为间隔时间
	bool tg=false;   
	memset(arr,0,sizeof(arr));
	for(int i=beg;i<fin;i++)
	{
		if(vis[i]) {arr[len]++;tg=true;}
		if(!vis[i] && tg) {len++;tg=false;}
	}
	sort(arr,arr+len,cmp);con=arr[0];  //排序求出最大值,

	len=0;tg=false;memset(arr,0,sizeof(arr));
	for(int i=beg;i<fin;i++)
	{
		if(!vis[i]) {arr[len]++;tg=true;}
		if(vis[i] && tg) {len++;tg=false;}
	}
	sort(arr,arr+len,cmp);bre=arr[0];
	printf("%d %d\n",con,bre);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值