USACO--Palindromic Squares

Palindromic Squares
Rob Kolstad

Palindromes are numbers that read the same forwards as backwards. The number 12321 is a typical palindrome.

Given a number base B (2 <= B <= 20 base 10), print all the integers N (1 <= N <= 300 base 10) such that the square of N is palindromic when expressed in base B; also print the value of that palindromic square. Use the letters 'A', 'B', and so on to represent the digits 10, 11, and so on.

Print both the number and its square in base B.

PROGRAM NAME: palsquare

INPUT FORMAT

A single line with B, the base (specified in base 10).

SAMPLE INPUT (file palsquare.in)

10

OUTPUT FORMAT

Lines with two integers represented in base B. The first integer is the number whose square is palindromic; the second integer is the square itself. NOTE WELL THAT BOTH INTEGERS ARE IN BASE B!

SAMPLE OUTPUT (file palsquare.out)

1 1
2 4
3 9
11 121
22 484
26 676
101 10201
111 12321
121 14641
202 40804
212 44944
264 69696


  这道题的题意是 让你输入进制,然后输出1-300中在某个数的平方这个进制下是回文数的话,就在这个进制下输出这个数本身和这个数的平方

思路:从1-300  每个数转换到对应的进制,如果是回文,就把数本身也转换一下,然后输出


代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#define maxn 1500
using namespace std;

char hash_arr[20]= {'0','1','2','3','4','5','6','7','8','9','A','B','C','D','E','F','G','H','I'};  //对应的进制转换
int base;

int is_dual(char* s,int len)     //判断是否为回文
{
    bool ok=true;
    for(int i=0; i<=len; i++)
    {
        if(s[i]!=s[len])
        {
            ok=false;break;
        }
    }
    return ok;
}

int base_trans(int n,char* tr)  //将数的平方转换成 对应的进制,然后去判断是否回文
{
    int len=0;
    while(n)
    {
        tr[len++]=hash_arr[n%base];
        n/=base;
    }
    return len;    //返回转换后的字符串的长度
}

int main()
{
    scanf("%d",&base);
    char tr[maxn],num[maxn];
    for(int i=0; i<=300; i++)
    {
        memset(tr,0,sizeof(tr));
        memset(num,0,sizeof(num));
        int lensqu=base_trans(i*i,tr);  //lensqu是平方数转换后的长度
        if(is_dual(tr,len-1))
        {
            int lennum=base_trans(i,num);  //lennum是数本身转换后的长度
            for(int j=lennum-1; j>=0; j--)   
                printf("%c",num[j]);
            printf(" ");
            for(int j=lensqu-1; j>=0; j--)
                printf("%c",tr[j]);
            printf("\n");
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值