poj1118(Lining Up)

7 篇文章 0 订阅
5 篇文章 0 订阅

 题目大意是这样:给出n个点的坐标,判断在这些点中最多有多少个点共线。。。

我开始的思路是用暴力,找出前两个点的连线然后再从生下的点中找出斜率相同的点记录并且统计个数,最后找出统计的个数中最大的,时间复杂度是O(n^3)数据最大是700,所以我开始希望可以险过,可是结果没过,所以我就又换了一种思路重新思考,对于从每个起点开始,记录每种斜率的个数,最后返回最大值,这种算法只用了O(n^2)

Lining Up
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 15964 Accepted: 5003

Description

"How am I ever going to solve this problem?" said the pilot.

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number?


Your program has to be efficient!

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.

Output

output one integer for each input case ,representing the largest number of points that all lie on one line.

Sample Input

5
1 1
2 2
3 3
9 10
10 11
0

Sample Output

3

 

***********************、、、、、、超时代码、、、、、、、、、、、、、***********

#include<cstdio>
#include<iostream>

using namespace std;

struct point{
    int x,y;
}dian[750];
int n;

double xielv(point p1, point p2){
    return (double)(p1.y - p2.y)/(double)(p1.x - p2.x);
}
int cal_xielv(){
    int max = 0;
    int geshu;
    for(int i = 0; i < n - 1;i++){
        if(n - i < max){break;}
        for(int j =  i + 1; j < n; j++){
            geshu = 2;
            if(n - j < max){break;}
            for(int k = j + 1; k < n; k++){
                if(dian[i].x == dian[j].x){
                    if(dian[j].x == dian[k].x){
                        geshu++;
                    }
                }
                else if(xielv(dian[i],dian[j]) == xielv(dian[j], dian[k])){
                    geshu++;
                }
            }
            if(geshu > max)  max = geshu;
        }
    }
    return max;
}
int main(){
    while(scanf("%d", &n)&&n!=0){
        for(int i = 0; i < n; i++){
            scanf("%d%d", &dian[i].x, &dian[i].y);
        }
        printf("%d\n", cal_xielv());
    }
    return 0;
}


以下为AC代码:

708K313MS

开始的时候我把max初始化为0,造成了一个很难查找的错误,因此接着就很长一串wa,真是悲剧啊,下次注意了、、、、、、、

#include<iostream>
#include<cstdio>
#include<cstdlib>
using namespace std;

struct point{
    int x,y;
}dian[750];
int n;
const int INF = 0x7fffffff;
double lie_xie[750];
double xielv(point p1, point p2){
    return (double)(p1.y - p2.y)/(double)(p1.x - p2.x);
}

int cmp(const void *a,const void *b){
    return *(double *)a > *(double *)b ? 1 : -1;
}
int cal_xielv(){
    int max = 2;
    int geshu;
    for(int i = 0; i < n;i++){
        geshu = 2;
        int xienum = 0;//斜率个数
        for(int j = i + 1; j < n; j++){
            if(dian[i].x == dian[j].x){
                lie_xie[xienum++] = INF;
            }
            else {
                lie_xie[xienum++] = xielv(dian[i], dian[j]);
            }
        }
        qsort(lie_xie,xienum,sizeof(lie_xie[0]),cmp);
        for(int k = 0; k < xienum - 1;k++){
            if(lie_xie[k] == lie_xie[k + 1]){
                ++geshu;
                if(geshu > max)  max  = geshu;
            }
            else geshu = 2;
        }
    }
    return max;
}
int main(){
    while(scanf("%d", &n)&&n!=0){
        for(int i = 0; i < n; i++){
            scanf("%d%d", &dian[i].x, &dian[i].y);
        }
        printf("%d\n", cal_xielv());
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值