OJ 2215 Problem B 时间之差

Description

定义一个类Time,包含小时、分钟、秒三个属性。定义其构造函数Time(int, int,
int)分别初始化其小时、分钟、秒。重载减法运算符,用于求两个时间之间相差的秒数(非负整数)。

Input

输入有2行。每行表示1个时间,包括小时、分钟、秒三个值。输入都是合法的24小时制的时间。

Output

见样例。

Sample Input

12 10 10
10 20 20

Sample Output

Deference is 6590 seconds.

HINT

Append Code

int main()
{
    int a, b, c;
    cin>>a>>b>>c;
    Time t1(a, b, c);
    cin>>a>>b>>c;
    Time t2(a, b, c);
    cout<<"Deference is "<<(t2 - t1)<<" seconds."<<endl;
    return 0;
}

Accepted Code

#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

class Time {
    int h, m ,s;
public:
    Time(int H, int M, int S) : h(H), m(M), s(S) {}
    int operator-(Time& time) {
        int sum1 = h*3600 + m*60 + s;
        int sum2 = time.h*3600 + time.m*60 + time.s;
        return fabs(sum1 - sum2);
    }
};
int main()
{
    int a, b, c;
    cin>>a>>b>>c;
    Time t1(a, b, c);
    cin>>a>>b>>c;
    Time t2(a, b, c);
    cout<<"Deference is "<<(t2 - t1)<<" seconds."<<endl;
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值