poj2182-Lost Cows

Lost Cows

Description

N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

Given this data, tell FJ the exact ordering of the cows.

Input

* Line 1: A single integer, N

* Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

Output

* Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

Sample Input

5
1
2
1
0

Sample Output

2
4
5
3
1

因为是树状数组训练所以必须用树状数组,其实应该有很多解决方案……硬套树状数组做的,感觉有些别扭。

根据题意,容易想到对于最后一位的奶牛,假设它之前有n头奶牛比它号牌大,那么它的编号就为n+1。

根据此基本思想,可以确定解题思路:从最后一位一直向前推导。找出最后一位的号牌,二分查找找出该号牌所属的号码sum(n)。之后将该号码的所有父节点-1,表示查找时索要找的sum(n)应比原来小1。

代码:

#include <cstdio>
#include <algorithm>
#include <string>
#include <cstring>
#include <stack>
#include <cmath>
#include <queue>
#include <list>
#include <cstdlib>
#include <vector>
#include <set>
#include <map>
#include <sstream>
#include <iostream>
#include <stack>
using namespace std;

int a[8005],c[8005],n,ans[8005];

int lowbit(int x){
    return x&(-x);
}

void add(int x,int num){
    while (x<=8000) {
        c[x]+=num;
        x+=lowbit(x);
    }
}

int sum(int x){
    int s=0;
    while (x) {
        s+=c[x];
        x-=lowbit(x);
    }
    return s;
}

int bin_find(int x){
    int l=1,r=n+1,m;
    while (l<r) {
        m=(l+r)/2;
        if (x>sum(m)) l=m+1;
        else r=m;
    }
    return l;
}

int main(){
    while (cin>>n) {
        memset(c, 0, sizeof(c));
        memset(a, 0, sizeof(a));
        for (int i=2; i<=n; i++) {
            add(i, 1);
        }
        for (int i=2; i<=n; i++) {
            scanf("%d",&a[i]);
        }
        a[1]=0;
        for (int i=n; i>=1; i--) {
            ans[i]=bin_find(a[i]);
            add(ans[i], -1);
        }
        for (int i=1; i<=n; i++) {
            printf("%d\n",ans[i]);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值