UVa-1220 Party at Hali-Bula (最大独立集)

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

Dear Contestant,

I'm going to have a party at my villa at Hali-Bula to celebrate my retirement from BCM. I wish I could invite all my co-workers, but imagine how an employee can enjoy a party when he finds his boss among the guests! So, I decide not to invite both an employee and his/her boss. The organizational hierarchy at BCM is such that nobody has more than one boss, and there is one and only one employee with no boss at all (the Big Boss)! Can I ask you to please write a program to determine the maximum number of guests so that no employee is invited when his/her boss is invited too? I've attached the list of employees and the organizational hierarchy of BCM.


Best, 
-Brian Bennett


P.S. I would be very grateful if your program can indicate whether the list of people is uniquely determined if I choose to invite the maximum number of guests with that condition.

Input 

The input consists of multiple test cases. Each test case is started with a line containing an integer n(1$ \le$n$ \le$200) , the number of BCM employees. The next line contains the name of the Big Boss only. Each of the following n - 1 lines contains the name of an employee together with the name of his/her boss. All names are strings of at least one and at most 100 letters and are separated by blanks. The last line of each test case contains a single 0

Output 

For each test case, write a single line containing a number indicating the maximum number of guests that can be invited according to the required condition, and a word Yes or No, depending on whether the list of guests is unique in that case. 

Sample Input 

6
Jason
Jack Jason
Joe Jack
Jill Jason
John Jack
Jim Jill
2
Ming
Cho Ming
0

Sample Output 

4 Yes
1 No

题意:公司里n个人,除老板外每个人都有直属上司,要求选尽量多的人,但不能同时选一个人和他的直属上司,问最多能选多少人,该方案是否唯一。

基本是一个裸的树的最大独立集问题,紫书上解释的很详尽,方法也很直白。

#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
#define INF 0x3f3f3f3
const int N=100005;
const int mod=1e9+7;

int n,t;
int d[205][2],f[205][2];

map<string, int> mp;
vector<int> sons[205];

int dp(int u,int k) {
    f[u][k]=1;
    d[u][k]=k;
    for (int i=0; i<sons[u].size(); i++) {
        int v=sons[u][i];
        if (k==1) {
            d[u][1]+=dp(v, 0);
            if (!f[v][0]) f[u][1]=0;
        } else {
            d[u][0]+=max(dp(v,0),dp(v, 1));
            if (d[v][0]==d[v][1]) f[u][k]=0;
            else if (d[v][0]>d[v][1]&&!f[v][0]) f[u][k]=0;
            else if (d[v][1]>d[v][0]&&!f[v][1]) f[u][k]=0;
        }
    }
    return d[u][k];
}

int main() {
    string  s1,s2;
    while (cin>>n>>s1) {
        int cnt=0;
        mp.clear();
        if (!mp.count(s1)) {
            mp[s1]=cnt++;
        }
        for (int i=0; i<n; i++) {
            sons[i].clear();
        }
        for (int i=1; i<n; i++) {
            cin>>s1>>s2;
            if (!mp.count(s2)) {
                mp[s2]=cnt++;
            }
            if (!mp.count(s1)) {
                mp[s1]=cnt++;
            }
            sons[mp[s2]].push_back(mp[s1]);
        }
        printf("%d ",max(dp(0, 0), dp(0, 1)));
        bool unique=false;
        if (d[0][0]>d[0][1]&&f[0][0]) unique=true;
        if (d[0][1]>d[0][0]&&f[0][1]) unique=true;
        if (unique) {
            printf("Yes\n");
        } else printf("No\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值