ZOJ Problem Set - 3946 Highway Project

Highway Project

Time Limit: 2 Seconds       Memory Limit: 65536 KB

Edward, the emperor of the Marjar Empire, wants to build some bidirectional highways so that he can reach other cities from the capital as fast as possible. Thus, he proposed the highway project.

The Marjar Empire has N cities (including the capital), indexed from 0 to N - 1 (the capital is 0) and there are M highways can be built. Building the i-th highway costs Ci dollars. It takes Diminutes to travel between city Xi and Yi on the i-th highway.

Edward wants to find a construction plan with minimal total time needed to reach other cities from the capital, i.e. the sum of minimal time needed to travel from the capital to city i (1 ≤ i ≤ N). Among all feasible plans, Edward wants to select the plan with minimal cost. Please help him to finish this task.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first contains two integers NM (1 ≤ NM ≤ 105).

Then followed by M lines, each line contains four integers XiYiDiCi (0 ≤ XiYi < N, 0 < DiCi < 105).

Output

For each test case, output two integers indicating the minimal total time and the minimal cost for the highway project when the total time is minimized.

Sample Input
2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 1 1
2 3 1 2
4 5
0 3 1 1
0 1 1 1
0 2 10 10
2 1 2 1
2 3 1 2
Sample Output
4 3
4 4

借鉴自:http://blog.csdn.net/u014445884/article/details/51232985



题意:

给你n个点,m条边。每条边有通过的时间花费,与修建该边的金钱花费。问你所有点(1~n-1)到点0的距离之和最小时,所花最少钱为多少。

分析:

dijkstra即可,根据距离和花费的要求不同优先级进行排序,求出答案。

看题的时候硬是没看懂题意,先看成最小生成树,后看成欧拉路反正就是个错,这要是打现场赛也是爆炸,看了题解才懂,懵逼。


#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cstdlib>
#include <string>
#include <fstream>
#include <vector>
#include <cstdio>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
#include <set>
using namespace std;
#define INF 0x3f3f3f3f
const int N=100005;
const int mod=1e9+7;

struct node {
    int x;
    long long d,c;
    node(int xx, long long dd, long long cc) {x=xx,d=dd,c=cc;}
    bool operator < (const node &p) const {
        return d>p.d;
    }
};

vector<node>  e[N];
priority_queue<node> q;
bool vis[N];
long long dis[N],cost[N];

void dij(int n) {
    for(int i=0;i<n;i++){
        dis[i]=1e12;
        cost[i]=1e12;
    }
    while (!q.empty()) q.pop();
    q.push(node(0, 0, 0));
    dis[0]=cost[0]=0;
    while (!q.empty()) {
        node p=q.top();
        q.pop();
        if (vis[p.x]) continue;
        vis[p.x]=1;
        for (int i=0; i<e[p.x].size(); i++) {
            node pp=e[p.x][i];
            int to=pp.x;
            long long dd=pp.d;
            if (dis[to]>dis[p.x]+dd) {
                dis[to]=dis[p.x]+dd;
                cost[to]=pp.c;
                q.push(node(to, dis[to], cost[to]));
            } else if (dis[to]==dis[p.x]+dd&&cost[to]>pp.c) {
                cost[to]=pp.c;
                q.push(node(to, dis[to], cost[to]));
            }
        }
    }
    long long ans1=0,ans2=0;
    for (int i=0; i<n; i++) {
        ans1+=dis[i];
        ans2+=cost[i];
    }
    cout<<ans1<<" "<<ans2<<endl;
}


int main() {
    int n,m,t;
    int x,y,d,c;
    cin>>t;
    while (t--) {
        cin>>n>>m;
        memset(e,0,(n+1)*sizeof e[0]);
        memset(vis, 0, sizeof(vis));
        
        for (int i=0; i<m; i++) {
            scanf("%d %d %d %d",&x,&y,&d,&c);
            e[y].push_back(node(x, d, c));
            e[x].push_back(node(y, d, c));
        }
        dij(n);
    }
    return 0;
}


给你n个点,m条边。每条边有通过的时间花费,与修建该边的金钱花费。问你所有点(1~n-1)到点0的距离之和最小时,所花最少钱为多少。

分析:

dijkstra即可,根据距离和花费的要求不同优先级进行排序,求出答案。

看题的时候硬是没看懂题意,先看成最小生成树,后看成欧拉路反正就是个错,这要是打现场赛也是爆炸,看了题解才懂,懵逼。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值