ZOJ Problem Set - 3710 Friends(暴力)

ZOJ Problem Set - 3710
Friends
Time Limit: 2 Seconds Memory Limit: 65536 KB

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than k friends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < n, ui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.
Output

For each case, print one line containing the answer.
Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

2
0
4
题目大意:一共有n个人,其中有m对朋友关系,并且,如果两个人之间有共同的好友超过k个,那么这两个人也会成为好友,问,有新产生的几对新的朋友?
方法:暴力暴力。。之间创一个二维数组记录两个人是否为朋友关系,然后遍历一遍,判断。

#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<cctype>
#include<cstdio>
#include<cmath>
#include<map>
#include<queue>
#include<vector>//集合    __gcd(a,b)求最大公约数
#include<iomanip>//保留小数//cout<<fixed<<setprecision(6)<<a;//std::ios::sync_with_stdio(false);
#define eps 1e-7
using namespace std;
int main(void)
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,m,k,a[105][105];
        scanf("%d%d%d",&n,&m,&k);
        for(int i=0;i<n;++i)
            for(int j=0;j<n;++j)
                a[i][j]=0;
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            a[x][y]=a[y][x]=1;
        }
        int sum=0,z;
        for(int i=0;i<n;++i)
        {
            for(int j=0;j<n;++j)
            {
                int ans=0;
                if(i!=j&&a[i][j]==0)
                {
                    for(z=0;z<n;++z)
                    {
                        if(a[i][z]==1&&a[j][z]==1)
                            ans++;
                    }
                    if(ans>=k)
                    {
                        a[i][j]=a[j][i]=1;
                        sum++;
                        i=0;
                        break;
                    }
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值