HDU 1097 A hard puzzle(找规律,快速幂)

77 篇文章 0 订阅
40 篇文章 0 订阅

A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 35063    Accepted Submission(s): 12599


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.
 

Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)
 

Output
For each test case, you should output the a^b's last digit number.
 

Sample Input
  
  
7 66 8 800
 

Sample Output
  
  
9 6
求a^b.因为只要求得出最后一位,所以只需要进行最后一位的幂运算就行,然而那样对于2^30数据肯定会超时。

这个题很显然是有规律的,例如7,7^1%10=7 , 7^2%10=9 , 7^3%10=3 , 7^4%10=1 , 7^5%10=7

下面是代码


<span style="font-size:18px;">#include <stdio.h>
int a[10];
int main()
{
	int x,y,i;
	while(~scanf("%d %d",&x,&y))
	{
		x=x%10;
		i=0;
		a[0]=x;
		do
		{
			i++;
			a[i]=(a[i-1]*x)%10;
		}while(a[i]!=x);
		
		printf("%d\n",a[(y-1)%i]);
	}
	return 0;
}</span>


刚刚又学了一种解决该题目的方法,叫做快速幂。直接上AC代码,不解释,自行百度吧。

#include <stdio.h>
int PowerMod(int a,int b,int c)
{
	int ans=1;
	a%=c;
	while(b>0)
	{
		if(b%2)
			ans=(ans*a)%c;
		b/=2;
		a=(a*a)%c;		
	}
	return ans;
}

int main()
{
	int a,b;
	while(~scanf("%d %d",&a,&b))
	{
		printf("%d\n",PowerMod(a,b,10));
	}
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值