HDU 1500 Chopsticks(动态规划)

77 篇文章 0 订阅
17 篇文章 0 订阅

Chopsticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1885    Accepted Submission(s): 882


Problem Description
In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He uses a set of three chopsticks -- one pair, plus an EXTRA long chopstick to get some big food by piercing it through the food. As you may guess, the length of the two shorter chopsticks should be as close as possible, but the length of the extra one is not important, as long as it's the longest. To make things clearer, for the set of chopsticks with lengths A,B,C(A<=B<=C), (A-B)^2 is called the 'badness' of the set.
It's December 2nd, Mr.L's birthday! He invited K people to join his birthday party, and would like to introduce his way of using chopsticks. So, he should prepare K+8 sets of chopsticks(for himself, his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K+8 sets, so that the total badness of all the sets is minimized.
 

Input
The first line in the input contains a single integer T, indicating the number of test cases(1<=T<=20). Each test case begins with two integers K, N(0<=K<=1000, 3K+24<=N<=5000), the number of guests and the number of chopsticks. There are N positive integers Li on the next line in non-decreasing order indicating the lengths of the chopsticks.(1<=Li<=32000).
 

Output
For each test case in the input, print a line containing the minimal total badness of all the sets.
 

Sample Input
  
  
1 1 40 1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98 103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164
 

Sample Output
  
  
23 Note For the sample input, a possible collection of the 9 sets is: 8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160

终于是自己独自想出的一道DP题了,心里激动万分!

分析:一看给出的数据那么大,1000 和5000,用搜索很显然不实际,所以想到了DP。人数从i  =1~ k+8,先找到1个人3只筷子时,

最小困难度,再逐渐找到1个人n只筷子的最小困难度,然后再找2个人6只筷子的最小困难度...

状态转移方程为:

dp[ i ][ j ]=min{ dp[ i ][ j-1 ],dp[ i-1 ][ j-2 ] + (a[ j ]-a[ j-1 ])*(a[ j ]-a[ j-1 ]) }

代码如下:

#include <stdio.h>
int dp[1010][5005];
int main()
{
	int i,j;
	int a[5005];
	int T,n,k;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d %d",&k,&n);
		for(i=n;i>=1;i--)
			scanf("%d",a+i);
		
		for(i=0;i<=k+8;i++)
		{
			for(j=0;j<=n;j++)
				dp[i][j]=32005;
		}
		
		for(j=0;j<=n;j++)
			dp[0][j]=0;
		
		for(i=1;i<=k+8;i++)
		{
			for(j=3*i;j<=n;j++)
			{
				if(dp[i][j-1]>dp[i-1][j-2]+(a[j]-a[j-1])*(a[j]-a[j-1]))
					dp[i][j]=dp[i-1][j-2]+(a[j]-a[j-1])*(a[j]-a[j-1]);
				else
					dp[i][j]=dp[i][j-1];
			}
		}
		printf("%d\n",dp[k+8][n]);
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值