POJ 2965 The Pilots Brothers' refrigerator(回溯查找,dfs)

27 篇文章 0 订阅
23 篇文章 0 订阅

The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23414 Accepted: 9004 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

题意:一个冰箱4*4个锁,‘-’代表开,‘+’代表关,要求所有锁都开才能打开冰箱,每个锁转换的时候,它所在行和所在列都会转换,即‘-’会变成‘+’,‘+’会变成‘-’。

求最少打开冰箱的步数,并输出转换锁的坐标。

DFS搜索,构造一个二叉树,开状态和关状态。

代码如下:

#include <stdio.h>
typedef struct node{
	int x;
	int y;
}Node;
Node a[16];
Node temp[20];
char map[5][5];
int Min;

int judge()
{
	int i,j;
	for(i=0;i<4;i++)
	{
		for(j=0;j<4;j++)
			if(map[i][j]=='+')
				return 0;
	}
	return 1;
}

void backtrack(int t,int x,int y,int min)
{
	int i;
	if(min>Min)
		return ;
	if(t==16)
	{
		if(judge())
		{
			if(min<Min)
			{
				Min=min;
				for(i=0;i<Min;i++)
					temp[i]=a[i];
			}
				
		}
		return ;
	}
	
	backtrack(t+1,(t+1)/4,(t+1)%4,min);
	
	for(i=0;i<4;i++)
	{
		map[x][i] = (map[x][i]=='-') ? '+':'-';
		map[i][y] = (map[i][y]=='-') ? '+':'-';
	}
	map[x][y] = (map[x][y]=='-') ? '+':'-';
	
	a[min].x=x;
	a[min].y=y; 
	
	backtrack(t+1,(t+1)/4,(t+1)%4,min+1);
	
	for(i=0;i<4;i++)
	{
		map[x][i] = (map[x][i]=='-') ? '+':'-';
		map[i][y] = (map[i][y]=='-') ? '+':'-';
	}
	map[x][y] = (map[x][y]=='-') ? '+':'-';
}

int main()
{
	int i,j;
	for(i=0;i<4;i++)
		scanf("%s",map[i]);
	Min=20;
	backtrack(0,0,0,0);
	printf("%d\n",Min);
	for(i=0;i<Min;i++)
		printf("%d %d\n",temp[i].x+1,temp[i].y+1);
	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值