It's All In The Mind

It's All In The Mind

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 422    Accepted Submission(s): 191


Problem Description
Professor Zhang has a number sequence a1,a2,...,an . However, the sequence is not complete and some elements are missing. Fortunately, Professor Zhang remembers some properties of the sequence:

1. For every i{1,2,...,n} , 0ai100 .
2. The sequence is non-increasing, i.e. a1a2...an .
3. The sum of all elements in the sequence is not zero.

Professor Zhang wants to know the maximum value of a1+a2ni=1ai among all the possible sequences.
 

Input
There are multiple test cases. The first line of input contains an integer T , indicating the number of test cases. For each test case:

The first contains two integers n and m (2n100,0mn) -- the length of the sequence and the number of known elements.

In the next m lines, each contains two integers xi and yi (1xin,0yi100,xi<xi+1,yiyi+1) , indicating that axi=yi .
 

Output
For each test case, output the answer as an irreducible fraction " p / q ", where p , q are integers, q>0 .
 

Sample Input
  
  
2 2 0 3 1 3 1
 

Sample Output
  
  
1/1 200/201
 
题目的大意就是给出最多100的数字的队列,这个队列是非递增的,里面的数字的范围是[0,100],要你求a1+a2和该队列的总和的最大值的比值,要求这个比值最大。


说白了就是分子是固定的,分母是在分子的基础上加上一些数,那很简单,我们只要加上去的数字保证是不违反规则的情况下是最小的就行了,而分子越大越好。

所以如果a1和a2没有赋值,肯定要给100的,如果赋值了就按规则来给最大值。判断玩第一第二个后就去从后往前遍历,一直到3,按照规则来给最小值,一开始如果都没赋值,那就给0,赋值了的话就维护最小值,更新一下,向前接着放这个最小值


#include<stdio.h>
#include<string.h>

int gcd(int x,int y)
{
    return y==0?x:gcd(y,x%y);
}
int main()
{
    int T,n,m,a[105],sum,max,x,y,i,min;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        memset(a,-1,sizeof(a));
        while(m--)
        {
            scanf("%d%d",&x,&y);
            a[x]=y;
        }
        
        max=100;
        if(a[1]==-1)
            a[1]=100;
        else
            max=a[1];
        if(a[2]==-1)
            a[2]=max;
        else
            max=a[2];
        
        min=0;    
        sum=0;
        for(i=n;i>2;i--)
        {
            if(a[i]==-1)
            {
                a[i]=min;
            }
            else
            {
                min=a[i];
            }
            sum+=a[i];
        }    
        max=a[1]+a[2];
        sum+=max;//答案输出要求是不可约的,所以用gcd找出最大公约数再相除就行
        x=gcd(max,sum);
        if(x!=0)
        {
            max/=x;
            sum/=x;
        }        
        printf("%d/%d\n",max,sum);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值