HDU5742 It's All In The Mind

题目链接:HDU5742

It's All In The Mind

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 856    Accepted Submission(s): 400


Problem Description
Professor Zhang has a number sequence  a1,a2,...,an . However, the sequence is not complete and some elements are missing. Fortunately, Professor Zhang remembers some properties of the sequence:

1. For every  i{1,2,...,n} 0ai100 .
2. The sequence is non-increasing, i.e.  a1a2...an .
3. The sum of all elements in the sequence is not zero.

Professor Zhang wants to know the maximum value of  a1+a2ni=1ai  among all the possible sequences.
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains two integers  n  and  m   (2n100,0mn)  -- the length of the sequence and the number of known elements.

In the next  m  lines, each contains two integers  xi  and  yi   (1xin,0yi100,xi<xi+1,yiyi+1) , indicating that  axi=yi .
 

Output
For each test case, output the answer as an irreducible fraction " p / q ", where  p q  are integers,  q>0 .
 

Sample Input
  
  
2 2 0 3 1 3 1
 

Sample Output
  
  
1/1 200/201
 

Author
zimpha
 

Source
 

Recommend
wange2014
 

题意:一组序列,要求后项比前项小。问那个式子的最大值。

题目分析:显然a1a2在整体的比重要尽可能的大,这样得出,a1a2取可取范围的最大值,其余的数取最小值。遍历一遍就好了。

//
//  main.cpp
//  It's All In The Mind
//
//  Created by teddywang on 2016/7/23.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int ans1,ans2;
int T,m,n;
int a[105];

int gcd(int a,int b)
{
    return a%b==0?b:gcd(b,a%b);
}

int main()
{
    cin>>T;
    while(T--)
    {
        cin>>n>>m;
        ans1=ans2=0;
        memset(a,0,sizeof(a));
        for(int i=0;i<m;i++)
        {
            int b1,b2;
            cin>>b1>>b2;
            a[b1]=b2;
        }
        if(a[1]==0) a[1]=100;
        if(a[1]==0&&a[2]==0) a[2]=100;
        else if(a[1]!=0&&a[2]==0) a[2]=a[1];
        int buf=0;
        ans1+=a[1]+a[2];
        ans2=ans1;
        for(int i=n;i>=3;i--)
        {
            if(a[i]==0)
            {
                ans2+=buf;
            }
            else
            {
                ans2+=a[i];
                buf=a[i];
            }
        }
        int d=gcd(ans2,ans1);
        printf("%d/%d\n",ans1/d,ans2/d);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值