POJ3281Dinicing(网络流初步)

                                                            Dining
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15644 Accepted: 7083

Description

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and preparedD (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input

Line 1: Three space-separated integers: N, F, and D
Lines 2.. N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output

Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes

Sample Input

4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3

Sample Output

3

Hint

One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

题意就是:有1到F种食物,1到D种饮料,然后有N头牛,每头牛有自己喜欢的食物和饮料,试着求最多有多少头牛可以吃到食物并且喝到饮料。

在明白题意之后,好好揣摩一下,明白了这为什么是网络流的模板题,然后开始建图,这是最关键的,建好图之后裸模板跑一次就好了。

代码如下:

#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
#define min(a,b) a < b ? a : b
const int MAXN = 405;
const int MAXN_INT = (1 << 29);

int n,F,D;
int sum;
int dis[MAXN];
int mp[MAXN][MAXN];

int bfs(int s)
{
    memset(dis, 0xff, sizeof(dis));
    dis[s] = 0;
    queue <int> que;
    que.push(s);
    while(!que.empty())
    {
        int top = que.front();
        que.pop();
        for(int i = 2; i <= sum; i++)
        {
            if(dis[i] < 0 && mp[top][i] > 0)
            {
                dis[i] = dis[top] + 1;
                que.push(i);
            }
        }
    }
    if(dis[sum] > 0) return true;
    return false;
}

int Find(int x, int low)
{
    int a = 0;
    if(x == sum) return low;
    for(int i = 1; i <= sum; i++)
    {
        if(mp[x][i] > 0 && dis[i] == dis[x] + 1)
             if(a = Find(i, min(low, mp[x][i])))
            {
                mp[x][i] -= a;
                mp[i][x] += a;
                return a;
            }
    }
    return 0;
}

int main()
{
#ifdef Floyd
    freopen("in.txt","r",stdin);
#endif // Floyd
    int tf, td, tmp;
    scanf("%d%d%d", &n, &F, &D);
    memset(mp, 0, sizeof(mp));
    sum = 1 + F + n + n + D + 1;
    for(int i = 2; i <= 1 + F; i++)//2 - 1+F
    {
        mp[1][i] += 1;
    }
    for(int i = 1 + F + n + n + 1; i < sum; i++)//1+F+n+1 - 1+F+n+D
    {
        mp[i][sum] += 1;
    }
    for(int i = 1 + F + 1; i <= 1 + F + n; i++)
    {
        mp[i][i + n] += 1;
    }
    for(int i = 1 + F + 1; i <= 1 + F + n; i++)
    {
        scanf("%d%d", &tf, &td);
        for(int j = 0; j < tf; j++)
        {
            scanf("%d", &tmp);
            mp[1 + tmp][i] = 1;
        }
        for(int j = 0; j < td; j++)
        {
            scanf("%d", &tmp);
            mp[i + n][1 + F + n + n + tmp] = 1;
        }
    }
    int ans = 0;
    while(bfs(1))
    {
        while(tmp = Find(1, MAXN_INT))
            ans += tmp;
    }
    printf("%d\n", ans);
    return 0;
}





  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值